2-digit vs 4-digit year bug

There seems to be a bug in the way that OMF 2 saves dates.

Suppose I enter the due date of a project as 12/31/2099 [1]. In the Due Date column this displays as 12/31/99 [2]. So far, so good.

Suppose I now change the date by deleting the 31 and replacing it with 29. The date displays as 12/29/99 as expected, but it the century gets changed to 19, so that the task suddenly becomes overdue.

It would seem to me that if the century is not explicitly edited, it shouldn’t get changed automatically.

FWIW, there is a workaround for this where I can go to System Preferences, then to Language and Region, then click the Advanced [sic] button, then change the year on the short date format to display 4 digits. When done editing in OMF, I can undo the change to thin the date columns again.

Perhaps this shortcoming is one built-in to OS X?

[1] This is an absurd due date but useful for Curt Clifton’s template scripts.
[2] This is controlled by how the system is displaying short dates, apparently.

1 Like

Hi There! I can reproduce this issue with your steps. I’ll make sure this is reported if it isn’t a known issue already. I appreciate you sharing your findings as well as a workaround with the forum here! Good find.