Action has context but doesn't appear in context view

Hi, this is an Omnifocus for Mac/iPhone question.

Earlier today on my mac I created some items for a shopping list and gave them the context “shop”. When I arrived at the shop I opened up Omnifocus on my iPhone, made sure it was sync’ed okay and switched to the context “shop” to find it was empty. I checked that it wasn’t just my view settings and set the view to ‘all’ but the items still didn’t appear.

In my preferences for Omnifocus on the mac I have the ‘clean up inbox items’ setting set to ‘both a project and a context’.

In the end I went back to my inbox with the view setting to ‘all’ and could see my items.

The actions/group weren’t ‘deferred’, ‘blocked’ or ‘on hold’.

I just presumed adding items to a context meant that they would always show up in that context regardless of whether I had ‘cleaned up’ my inbox and as long as the view was set appropriately.

Am I misunderstanding something?

Still learning and very appreciative of any help.

Thanks in advance,

Tom Wilcox

I tried a similar test on my side. Specifically:

  1. Created an action called “Buy Bananas” on my Mac and gave it a context of Errands, but no Project…meaning that it stayed in the inbox.
  2. Synced the changes to my iPhone.
  3. Tapped on Contexts > Errands

As I would expect, “Buy Bananas” is displayed under this context, even though it’s still in the Inbox. I can’t think why this isn’t working in your case. Consider contacting Omni Group support at: if this issue persists.

It might be a silly question, but are you sure that it synced before you walked out the door? The Mac is pretty good about auto syncing, but on the iOS devices I’m constantly syncing manually, just to be sure.

Thanks for testing my scenario I really have no idea why the problem occurred. I will keep an eye on it over the next few days.

I had definatley sync’ed it okay. When I found the items in my inbox they were assigned to the correct context but didn’t show up in said context.

The only other strange thing to happen was when I tried to complete the group action (which I have done in the past) it just flashed grey and refused to ‘complete’ with a tick. I just deleted it in the end.

Anyhow thanks very much for the replies, I appreciate it. If the problem occurs again I will repost in this thread.

This sounds like it might have been a repeating item, so completing it was immediately creating a fresh copy.

Is it possible you have two contexts with the same name?
When viewing an action, you can use the curly arrow to the right of the context to jump to that context. See if the arrow from that action takes you to the context you expected.