Adding Files / Dragging Files into Notes

I’m having trouble dragging files into the notes section in Actions. I used to be able to do this and now it doesn’t seem to work. I’m reading Kourosh Dini’s book on omnifocus and he gives an example using an iFlash file. It doesn’t seem to work for me. I noticed other messages in the form on this topic with no answers.

ACK! I’ve been struggling with the same. I have tried dragging files from my desktop or attachments from emails and plopping it into the Notes section in the action list, and the notes section of the inspector and in general I am unable to do so! I feel like I used to be able to but it’s, but I might just be making that up.

I’ve sent in a feature request to be able to use the inspector, since it is always open vs. the task note in the list which might need to be opened. I don’t understand why it isn’t a more requested feature.

Hello All!

You should definitely be able to drag files into the note field in the outline in OmniFocus. It seems like this works best if you place your cursor in the note field first and then drag a file in from Finder. A ‘normal’ drag should add the file as a linked attachment, or you can option-drag to embed the file in your OmniFocus database (we recommend limiting how often you embed attachments, though, as that can cause the database to get very large which can negatively impact sync performance). This section of our online documentation has more information about attaching files from Finder.

Not working. I just tried it again. I know I used to be able to do this, but it is not working.

Just so I am clear, this implies that dragging to the Notes field in the inspector is NOT supported? (Which is fine, I just want to be clear on what is and is not supposed to work!)

Hi @BobSeng, I’m sorry it’s not working for you! If you email us we’d be happy to troubleshoot with you!

Hi @scottisloud, I’m not sure whether it’s supposed to work or not (although I suspect that it is), but it definitely doesn’t work at the moment. We have a bug on file about it, which I’ll add you to.

If anyone else would like to report trouble dragging files into the note field please email us so we can be sure to your comments get where they need to go. Thank you!

1 Like

After some back and forth I now understand how to make this work. In my defense, it’s a little touchy.

  • I made sure cursor was in the “notes field” of the task in OmniFocus. I saw the cursor blinking.
  • Then, slowly, without to much coffee in my system, dragged an OmniOutliner file (perfect marriage of two great apps) into the “notes field” of the task in the outline view of OmniOutliner.
  • And … presto… it worked.

Biggest key for me was pausing and understanding what is meant by the “notes field” of the task in “outline view.”

1 Like