Adding focus to a perspective

So, I’ve created a new project and now want to create a perspective that focuses in on this project, but I can’t do it. Every other project no problem, I can add that to the focus of the newly created perspective, but this one just refuses to be added. Any ideas?

Sorry for the trouble! Would you be able to post some screenshots of the project and how you’re trying to add it to the perspective’s focus? It might help us determine what’s wrong here.

If you’d rather get one-on-one help, our support team can also try to figure out what’s going on - feel free to send them an email!

Sure, I can choose a project but I can’t add it to the perspective. Something makes it grayed out and I can’t understand why, all other projects are able to be added to the focus. No problems there.

Did you ever figure this out? I’m experiencing the same problem. Some projects I can not add to focus in a custom perspective. I can’t figure out any logic to when it is possible and when not.

I also doesn’t matter whether the projects are greyed out or not.


Well yes and no. No solution to get an existing projekt into a custom perspective, if they unable to be added I haven’t found a way to solve it. But, I worked around it by deleting the project, added it once again (same name and everything), and then it worked.

1 Like

Thanks. That sounds like a bug. I’ll send an email to Omni support and report back here.

Rebuilding the Omnifocus database fixed it for me — this is the answer I got from Omnifocus support:

Thanks for getting in touch about this behavior in OmniFocus! We are aware of a few bugs surrounding the Add to Focus feature for custom perspectives; one of the ways we’ve found to fix the particular issue you seem to be encountering is to rebuild your database in OmniFocus for Mac. To do this, open OmniFocus and select File > Rebuild Database from the menu bar.

1 Like

Thanks! Good advice if I run into this in the future!

I had this problem and rebuilding the database fixed it for me as well. Thank you!

In case it’s helpful to anyone:

Rebuilding the database did not immediately fix this issue for me, but after rebuilding the database I was able to add a(n unwanted) focus for one project, then add the one that I wanted, then delete the unwanted focus and my desired focus remained in the perspective.