Adding New Actions in a Custom Perspective

I am finding Omnifocus 3 exceptionally beneficial. I have spent the last few days creating a few perspectives that have materially improved my ability to maximize my productivity. However, for the first time today, I tried to add a new action to a project displayed in a custom Perspective. I selected the project, and then tried each of the following to no avail:

  • Enter key
  • context-click on the project and select “New Action” from the popup menu (the menu item was enabled)
  • Click the “New Action” button in the header (plus sign icon)
  • Select “New Action” from the File menu (the menu item was enabled)

I tried selecting an Action within the Project and performing the same actions, to no avail.

When doing any of these actions, the focus remains the same and nothing on screen changes. A new Action is not created. The same is true if I choose to Focus on the project by clicking on it in the custom Perspective, regardless of whether I simply choose “Focus” in the current window, or either of the options to focus in a new tab/window.

Should I be able to add new actions from a custom Perspective when I have selected a Project, and/or a Focus window displaying a single project? I presume so because the “New Action” menu items are enabled?

1 Like

Yeah, that won’t work if you’ve got your “Group and sort” setting set to “Individual Actions”. Setting it to “Entire Projects” will work, though that might be undesirable for other reasons. The options for adding a new action should probably be disabled in this case, however.

Thanks, @deaghean!

I tried that, and here’s an update. The project titles were showing in the custom perspective, but it was set to Group and Sort by “Individual Actions”. It occurred to me that this didn’t seem right, so I toggled the setting to “Entire Project”. The display didn’t change. I toggled it to “Individual Actions” and the project titles disappeared (as they should). When I toggled it back to “Entire Project”, the project titles again appeared, and I could add a new action once I had clicked on a project title.

In short, the display seemed to be out of sync with the setting. The menu items were enabled (as the display would suggest they should be), but the actual addition of a new action was prohibited (in alignment with the actual setting).

I can’t recreate the situation on the Mac. I created the custom perspectives on an iPad. Perhaps that had something to do with it. If I can spare the time later, I’ll try to recreate starting on the iPad.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.