Aligning Numbers in a Column Right

Hi can anyone tell me how to align numbers in a column to the right. I can only get all columsn in a row to align the same but some columns need to be left aligned and others (like numbers) right. Thanks in advance

If the column only contains numbers, you may wish to set the Column Type to ‘Number’. To do that, click on the column header to select the entire column (headers should be visible, but if not, go to View > Column Headers > Show).

Next, open the Inspector. It should open automatically to the ‘Columns’ section, but if not, it’s the second icon from the left. There, change the type to ‘Number’.

You can customise the formatting for it as well. The summary will show the selected feedback in parent rows.

If you don’t want to change the column type, you can also simply change the alignment for the column by switching over to the Style section.

Hi thanks for your reply. I already have the column type set to numbers but it is still aligning them to the left. I can’t work out why. Any other ideas?



How curious. Perhaps you have the alignment set in a style that affects the column? Failing that, what if you set the alignment manually after selecting the column?

I’ve tried setting manually but I will have a look at the styles when I next get access to my MacBook (this evening) and see if there is something there that needs tweaking. As you say it is very curious…

Finally fixed it! By changing data type back to rich text and then to number again it aligned right. Seems to have been a glitch in there somewhere. Thanks again for your help.

Hooray! That’s great news.