Attachments don't sync

Hi all,

To my big surprise I’ve noticed today that the attachments to tasks don’t sync between the iPhone and Mac (version 2) of OmniFocus.

I’ve tried it both ways, attaching first a pdf on the Mac and it didn’t sync. Then I’ve added a jpg (on the Mac) and it still didn’t sync. Then I tried from the iPhone, attached an image from the Camera Roll (jpg I think) and it again didn’t sync back to the Mac.

Is this not supported? (if not it’s a big bummer for me). If it is, am I doing something wrong?



Sorry for the trouble! Attachment sync should definitely be supported.

If you can, would you mind posting some screenshots of the iPhone and Mac tasks where you attached those files? It might help us shed some more light on what’s going on here.


What sort of file attachments are supposed to sync between platforms? At the moment I have a task with a pdf file attached to it and the pdf didn’t sync to my iPhone.

Here are the screenshots from mac and iPhone.

And from the iPhone (apparently I can only put one image per post):