Attachments In OF2

I’m having problems with attachments in omnifocus 2 and and wondering if anyone is experiencing a similar problem or if there is a solution.

When I embed a file in a task and try to open/edit the file, omnifocus always creates a new version of the file and appends a number to the file name and saves as a new version. This happens every time I open the file so if I open it 5 times I now have 5 versions.

The other problem is that OF isn’t opening the latest version, but seems to open the original file and save as a new version so any changes made to the document are not rolling forward.

I use file links when I can but there are times/tasks that I want/need an embedded document to edit and save within a task. I’m referring to desktop version and both OS and Omnifocus are up to date.

Thanks in advance.

Just checked to see if latest test build fixed the issue but I get the same results. If anyone can confirm if they can attache and edit file or if they have the same problem with the embedded file opening as locked or read only and changing file name much appreciated.

I think I notice this too. Yikes! This is terrible! This can very quickly use up all my disk space.

It’s not currently possible to edit embedded attachments in place. We do have this issue on our radar and I’ve added both of your comments the entry in our development database so the rest of the OmniFocus team knows this is something you’re struggling with. The only workarounds I’m aware of at this time would be to either link to the attachment rather than embed, or save your edits to someplace like the Desktop and then re-embed the edited copy and remove the previous version.

1 Like

Hi Anne

In Omnifocus 1 this worked perfectly and I used it a lot. When I attached files to a project I could open it, edit it, save it and open it again later from Omnifocus. (I could also open the file directly from my folder in Finder). This saved a lot of time when working with projects. Now I´m doing the same thing - using the “attachment” button to attach files. But everything seems to be complete mess now and I can´t use this function at all. In fact I can´t see it can be used for anything at all the way it works now.

It´s fine with me to just link to the file (I actually thought that Omnifocus 1 was doing that when I used the “attach” button). But how do I do that? The “attach” button seems to embed.


What ‘attachment button’ are you referring to? I’m not seeing that in either version 1 or 2 of OmniFocus. Is it something you’ve customized?

It sounds like you probably were linking those attachments in version 1, rather than embedding them. The default behavior (when attaching files by selecting Menu Bar ▸ Edit ▸ Attach File… or using the contextual menu option), in OmniFocus 1 was to link them, whereas the default in OmniFocus 2 is to embed them, so that’s probably the difference you’re noticing. Had you been embedding them in OmniFocus 1 you would’ve had to open those attachments from inside the hidden Library folder within Finder in order to edit them outside of OmniFocus, which would almost certainly not be something a person would do unknowingly (it’s a rather complex process).

You should still be able to link to a file by either selecting Menu Bar ▸ Edit ▸ Attach File… and choosing ‘Create a link to the file’ (instead of ‘Embed the file in the document’), or by dragging it from Finder (the default when dragging is to link, rather than embed). (Conversely, if you want to embed when dragging you can do so by holding down the ⌥ (option) key while dropping the file into OmniFocus.)

If you’re not sure how an existing attachment is attached, the easiest way to determine that is to control-click on the attachment in OmniFocus and select Reveal in Finder from the contextual menu. That should open a Finder window to the location of the file. If the file appears to be in a folder that you created along with other files you recognize, that attachment is linked. If the file appears to be buried deep within the hidden Library folder (inside the com.omnigroup.OmniFocus2 sandbox) that attachment is embedded.

1 Like

I never noticed that I could choose between “Embed the file in the document” and “create a link to the file”. You are right that I have simply been using the default behavior in OF 1 and 2.

The “attach” button is the one in the toolbar which I customized.

I justed tested the “create a link to the file” and unfortunately it doesn´t work very well. I´m able to link instead of embed. I can attach, open and edit a document. But after saving the document when I try to open it again from OF I have to go through an annoying step. Omnifocus says that “the attachment has been moved” even though that´s not the case. See the attached screenshot. I can open it after selecting it in the folder, but the idea of linking to a document should not be the browse the folder again to open it.

Is there a solution?

I am also encountering this behavior. I sent a report to OmniFocus support and hope that they’ll fix this in a future version.

@peterdue and @TheWart,

After searching our development database, it looks like we have a bug filed for the issue of those linked attachments claiming to need updating. Unfortunately, we haven’t been able to figure out a fix for that yet either, but we do know that it’s also related to Apple’s new sandboxing security requirements.

In case it’s helpful, one customer reported they were able to move their linked files to another location, then back again, update the links, and the issue resolved itself. I can’t say for certain that will be helpful in your case, but it may be worth a shot.

That said, I’ve added you both to the open report for this bug so that the rest of the OmniFocus team knows you’re being affected by it too. Sorry I don’t have a better solution for now, but hopefully we’ll be able to improve this in the future.

If anyone else happens upon this thread and would like their comments added to the open bug report on this, please send an email to and include a link to this forum thread URL.

1 Like

I have a feature request for how attachments are managed in OF2.

As it goes right now, if I attach a few photographs of different sizes, or Excel documents to a task, the images or thumbnails will populate together in an irregular way into OmniFocus2. The result is that they are difficult to differentiate from each other.

Instead, it would be nice that a standard sized thumbnail or placeholder is created for each image or document. Perhaps a mouseover would show a larger image. This way, consistency is maintained with how attachments look, allowing for easier management.

Great idea, @awedlake. I’d like to see something similar. Perhaps it isn’t far off. I recall that something like you describe was just implemented for OmniOutliner 2.3. Go ahead and shoot a request to Omni via the app’s Help menu. I’ll do the same.

I am having the same problem, AND WORSE on OmniFocus 2 Pro (2.2.1 v96.4). I get a FATAL CRASH! each time I try to open an embedded Omnioutliner file!

Please email, so we can help!

Was there ever any resolution to this issue? I’m seeing this in the latest version of OmniFocus 2 Pro over a year later.

1 Like