BUG: OO3 column settings override OO4 print settings

For a few weeks now I’ve been trying to figure out why my date column wouldn’t print. Searching in OO4, I couldn’t find any settings on whether to print a column or not. The help file revealed that simply hiding the column keeps it from printing. Alas, my column was plainly visible. Today I experimented by opening my outline in OO3 and going to the page setup function where one turns columns on and or off for printing. It was set to off. I turned it on, saved, closed, and reopened in OO4. Now my column prints.
I’ve repeated these steps a few times with the same results.
Is there a setting I missing, other than turning the column on/off for printing? If not, I submit that this must be a BUG in OO4 as I would think updating the setting for columns would flip the appropriate switch, etc.

On with the adventure, Scott