Bug report: Fit in Window behaves inconsistently


#1

I use Fit in Window all the time, and it behaves oddly in a way that seems buggy.

  1. When I use Fit in Window, it leaves a small gap around the edge of the canvas. When I page down to the next canvas, and page up back to the first canvas, the gap disappears. Screencast: http://recordit.co/EMDk4TiYLZ

  2. The gap below the canvas doesn’t disappear. Even when Fit in Window is active, there is still a gap. Screenshot: image

  3. Not all canvases have this gap. Another canvas in the same document, of the same size, doesn’t have the gap around it for some reason. It appears to be related to shared layers on the page, but none of them overlap the edges of the canvas.

  4. It seems odd that “Fit in Window” is implemented as a canvas mode, rather than merely a zoom action.


Current stable version?
#2
  1. I can’t tell if you are seeing a bug, or something expected. It will depend on the size and content of your canvas. It’s hard to tell for sure from your video. Please feel free to send us an example document from Contact Omni so we can take a look. You can choose to anonymize the attached document which will replace all of the text with the letter x if you prefer.

  2. A gap is expected if your canvas size is wider than it is tall. Fit in Window means the largest side of the canvas is scaled down to fit inside the window. If another side of a fixed canvas is larger, that will leave the void (gray gap above or below the canvas).

  3. It will depend on the size and content of the canvas. The content on a shared layer may make it fit into the window differently. In fact, based on which layers you are showing/hiding it might even fit inside the window differently.

  4. Fit in Window isn’t a canvas mode. It’s a zoom mode on the status bar that toggles on/off. If you pinch zoom, it automatically turns off. Zoom levels are set on each canvas, and remembered. You can select multiple canvases in the Sidebar and set the Zoom options. If you check under the View menu, you’ll see Zoom, and Fit to Window is located under there. There is also a button on the status bar so it is easier to toggle on and off while working in a document.

Flexible and Infinite are canvas modes and Fit in Window is a zoom action. You can change those in the Canvas Inspector.

Thanks,
Lanette


#3

Thanks for the response.

  1. I’m sending you a simple document showing these issues. It has 3 canvases, the first fits in window as expected, the other two have a gap, even though all 3 canvases are the same size with nothing outside the canvas edges. Here is a new screencast showing the entire window: http://recordit.co/hmS5B0fsqZ

  2. I’d expect gaps left+right or top+bottom, depending of the shape of the canvas and the window size. But my document’s canvas 2 & 3 have an unnecessary gap at the bottom only, in addition to the expected left+right gaps. They also have an unnecessary gap at the top, which disappears when I page to another canvas and back, as shown in the screencast.

  3. How can the canvas content affect “Fit in Window” if there’s nothing on the canvas outside the canvas bounds?

  4. Fit in Window acts like a mode, rather than an action, as can be seen by the state of the “Fit in Window” button on the status bar. And when the mode is disabled, things can act oddly. Let’s say you activate Fit in Window, then deactivate it. Nothing seems to change, as expected. But if you then PgUp, PgDn to the previous canvas and back, the zoom level is still the same but scrollbars have appeared. (Unnecessary, as there’s nothing outside the canvas.) And if you then PgDn, if this is the last canvas, you will page into the empty space below the canvas. This is also shown in the screencast.


#4

Thank you for sending in the example. We will look into this in detail.


#5

I also have Fit in Window issues. The canvas is never sized to fit in the window, and the top and bottom edges are always just outside the window. I’m using 7.10.2. The current (buggy) behavior is maddening.


#6

That will be fixed soon. If you hide your ruler it may help until then. Sorry for the trouble.


#7

Please update to OmniGraffle 7.11.1 or higher when that works for you. Otherwise, using Show Ruler should help avoid this bug until it is possible to update.

Thanks,

Lanette