Can't email to my Inbox? [fixed; see support article]

I used to be able to address an email to "" and have it show up in my OF inbox.

Now, it doesn’t. When I look in Mail:Services, I don’t see the OF service. Only if I highlight some text in a message, does Services show “OmniFocus2: Send to Inbox”.

I tried logging out and in, even rebooting. Nothing fixes this.

Any ideas?

Additional info …

I found a post on this forum that enabled me to re-install the Clip-O-Tron and use a keyboard shortcut to send an email to my inBox … but I still can’t get the to work. I’m looking for that, for the following workflow: if I sent someone an email that required a response I wished to wait for, I would BCC the outgoing message to my inbox and it would go into a Waiting context.

This was fewer steps for me than sending the message, going into the Sent mailbox, selecting the message, and then running the keyboard combination to Clip it.

I’m wondering if my problem is that the AppleScript that +omnifocus required is in a location that used to work and that under Mavericks no longer does. Any suggestions?

Why don’t you use the Omni Sync Server Mail drop service? The Mail drop does not depend on anything installed on your computer. You’ll just have to use another type of address, like

Hey @rogbar! Check out this support article on setting up the Mail Rule. (OmniFocus can no longer add it automatically because…sandboxing.)


from that article, the best way to do this is Mail Drop service. Here’s the article on how to do that. I just did it, works great.

My two cents.

The Mail Drop service is very handy and reliable. The one problem is it doesn’t support the parameters like assigning dates.

The implication here is that a user has to then monitor their inbox frequently. I believe with the previous email functionality a user could work out of other perspectives.

You can still use the Mail rule, you just have to set it up yourself since OmniFocus can’t reach out of its sandbox to do it for you. See the support article for details.