Can't enter a task that starts before today? [Try changing the project's start date and Clear Leveling]

I’m attempting to enter a task into OmniPlan (latest version) with a start date earlier than today. OmniPlan edits the task to start today, with a start-no-earlier constraint equal to the date that I want the task to start. The net effect is that you can’t create a project plan that contains anything that has already started.

This is a critical functionality - I can’t use OmniPlan for this project because of this limitation.

Set editing date as doesn’t work (it seems to have no effect at all) and even changing the system clock doesn’t help. This is either a bug or an incredibly obvious omission.

You can’t set a task date to begin before the start date of a project, but you can set a project’s start date to any date you want using the Project Inspector (Inspectors->Project->Information, or Command-4):

Does that solve your problem, I hope?

1 Like

Thanks - this wasn’t the solution (I’d checked that already) but it turned out to be a constraint on a parent task that I hadn’t explicitly entered so didn’t realize was there.

1 Like

LauraB’s post on the old board covers this as well - last reply before the end of the topic:

Any solution for this issue? I am also trying start OmniPlan in the middle of a project which started on 12/15/15. I am unable to set the start date to a previous date. Appreciate your response on this.

@sleela Does changing your current editing date (via Project > Set Current Editing Date… in the OmniPlan menu bar) to a date in the past help? If not, our Support team would be happy to look into this with you! They can be reached by email at

I am now faced with this same scenario. I want to transition my project plan for an in-flight project to Omniplan. I have built out my plan using undetermined project start date to be sure all my tasks and dependencies are correct. It looks perfect. Now I want to set the project start date to 31 October 2016. When I do this all the dates in the plan populate from today, 07 January 2017. I can find no way at all to get the project to schedule from the 31 October 2016 start date, which is when the real project started. Any tips?

My tasks are all set to start as soon as possible with no other constraints.

Update 1: I just tested this with a new, clean, simple project plan. Setting a project start date in the past does exactly what would be expected. When I do the same in my complex plan with hundreds of tasks it fails.

Update 2: SOLVED!!! After setting my actual project start date, which is in the past, I needed to go to Project > Clear Levelling. This then set all my tasks to really start as soon as possible. Now my project is starting in the past as I need it do.

1 Like

@ianwelles I’m glad to hear that you were able to sort this out!

This did it for me! Also had to move the start of the parent group back to where I wanted first, then alter the specific task I wanted