Cant sync database after upgrade [object which could not be resurrected]

Hi,

Im trying to sync my database after the upgrade from omnifocus 2. Unfortunately i got the following message, which says nothing to me.

What can i do to solve this problem?

Kind regards

btang

OmniFocus 3.0.1 Pro (v116.2.1.0.311191)

{
  code = 331;
  domain = “com.omnigroup.OmniFocus.XMLData.ErrorDomain”;
  userInfo =  {
    NSLocalizedDescription = “Reference of object which could not be resurrected Task/iyi5gcXSiK7.3”;
    “com.omnigroup.framework.OmniBase.ErrorDomain.FileLineAndNumber” = “/Volumes/Local/Shared/omnibuild/ReleaseProduct/Source/OmniGroup/Applications/OmniFocus/XMLData/Errors.m:57”;
  };
}

Email support and mention ‘resurrection’ error in the title. It’s been a problem in the past and hopefully they can get you sorted quickly.

If you need access to your database as soon as possible you can send the email to the urgent support box.

2 Likes

I just found a way to solve this problem.

  1. go to your omnifocus and select all the tasks
  2. got to https://wordtohtml.net/ and past your links on the left side. on the right side you see the omnifocus code
  3. in my case i got the following error
    “Reference of object which could not be resurrected Task/iyi5gcXSiK7.3”;

search for “iyi5gcXSiK7” and you see exactly which task it is

  1. go to omnifocus and delete that tasks. after that i was able to sync OF3 to my iphone and ipad

Hope this helps :-)

I had the same problem and got it resolved through email support pretty much the same way. Rather than having to follow your steps to identify the task in question, I was instructed to follow a link like this, from the ios device having the problem:

com.omnigroup.omnifocus2.ipad:///task/[YourTaskString]

Everything after “task/“ is the specific string reported in your error, of course. I don’t know if the part right before that has to say “iphone” instead of “ipad” if that’s your device, but I was on an iPad and it worked for me.

That opened OF2 direct to the problem task, which as the support human predicted, was an untitled inbox item with sub-items. I moved the sub-items out, deleted that problem task, and re-synced. When I then went pack to OF3 and tried to import/sync the old database again, it worked. I then tried it on my iPhone and it worked there, too, so I didn’t have to go through all the steps again. Fixing it on one appeared to fix it for all.

The support email also suggested additional steps of sending copy of the repaired db in a “replace sync database step”, but mine worked without having to do that. Same for the recommended step of deleting and reinstalling the OF3 app. I mention these steps in case anyone else tries the above and it hasn’t worked yet, but like I said, fewer steps got it working right for me.

2 Likes