Change default setting for "Complete when completing last action" for new projects?

IIRC, in OF 1 I was able to set a default preference whether I wanted new projects to be set to complete when the last action is completed. In OF 2, this seems to be set by default to checked (I typically want it unchecked). Is there a way to change this default behavior?

1 Like

Indeed, this would be very helpful . . .

1 Like

That’s weird, I don’t see that behaviour at all. Maybe there’s a hidden pref somewhere?


Projects aren’t set to auto-complete for me either. I recommend that you contact OmniFocus support ( on this one.

Per OG Support Ninjas:

While there isn’t a box to change this behavior any longer in the preferences, you can follow this URL to turn off the global setting for new projects:


If you want to go back to the new OF2 default, replace the “no” with “yes” like so:


How do you do this?

I still have this problem

Hi there!

Just thought I’d jump in and try to clarify things a little.

In OmniFocus 1 there were two settings that would control the behavior of projects or action groups when the last item was completed.

• The global setting in the OmniFocus 1 preferences controlled whether new projects or action groups had that setting turned ‘on’ or ‘off’ when they were created. This only affected newly created items.

• The setting in the inspector that controls whether that option is enabled or disabled for the existing project or action group that is being inspected.

Anyone still using OmniFocus 1 for Mac can change the global setting in the OmniFocus 1 preferences and it should sync to the other versions, while customers without access to version 1 can use these URLs to change the hidden preference in OmniFocus 2:



That setting only affects newly created items in both version 1 & 2. If you need to batch change the setting for multiple existing items you should be able to do that by selecting them all, and then using the inspector to check or uncheck the box for the selected items.

I hope this helps! If not, or if you have any other questions or suggestions, please don’t hesitate to email us at We’re happy to help!


Anne J.
Support Human
The Omni Group

Copy the URL and paste the copied text into the Address text field at the top of your Safari web browser. You might have to restart OmniFocus for it to take effect.