Clip-o-tron 3001 sometimes hangs

This happens to me 2-3 times/day and is a performance killer. I probably try to clip from mail 20 or so times per day.

Sometimes when clipping from mail to OF2 using the Clip-o-Tron 3001 plugin the clipping window appears but then takes a variably long time to populate from Mail. Sometimes I have grown so frustrated after 3 or 4 minutes of waiting (seriously), that I’ve force-quit omnifocus and tried again. Sometimes this works, other times it doesn’t. Today when it happened, I decided to go to lunch and leave it to see if it would do something useful like report an error. Mirabile dictu! It did:

Error executing handler script for <ScriptHandler:0x608000118300 com.omnigroup.OmniFocus.ScriptHandler.Mail NSBundle </Applications/> (not yet loaded)>: Can’t get message id 1542854 of mailbox “Outbox”.

And the clipping box was populated.

Anybody else seeing this? Know a workaround?

Getting hangs? Yes. Having the patience to wait them out if they last more than a minute before finally populating the Quick entry field? No.

Yeah, experiencing the same thing using clipping – through services shortcut – in Mac Mail. Big downgrade. My experience is that clipping works just fine when it’s a short message. But try to clip a thread of messages – which was instant in last version – can take MUCH longer, as in minutes.

Fix in sight?

Oh, and another glitch. It used to be that ctrl-opt-apple-space simply clipped from Mac Mail. Now it scrolls down in Mail, until at the end of the thread, THEN clips. Can involve hitting keys 5-10 times to get clipping. Have tried changing shortcut, but doesn’t seem to help. Advice?

1 Like


I’ve had this issue since the beta. So frustrating. No fix in sight.

Interesting. When this hangs for me, I can’t get any response out of the Quick entry field (and it stays on top if I switch to another application). I have to force-quit OF in order to regain control.

Exact same issue here. The behavior of the 3001 version is inconsistent at best and flaky.

I emailed Omni Group support and got the following answer:

Sorry this is an issue. Clipping uses AppleScript, which appears to have some serious performance issues in in OS X 10.9. We’ve got a bug filed on this, in case there’s anything we can do about it from our end. I’ve added a report of your troubles to the bug file. Apologies for the inconvenience in the meantime.

1 Like