Clipping mail without explicit selection

I’ve just upgraded from Mavericks (OSX 10.9) to El Capitan (10.11), and I’ve discovered a change in behavior for clipping email messages to OmniFocus. But I wonder if I’m just missing a setting somewhere.

If I select some text in an email message, and then invoke the system-wide shortcut I’ve set up for the “OmniFocus 2: Send to Inbox” service from Keyboard shortcuts in System Preferences, that works fine. But formerly, under OS X 10.9, I didn’t have to select part of an email message - as long as I had a message selected in the Mail viewer window and open for viewing, invoking the OmniFocus clipping shortcut would send that message to the inbox. That no longer works - it just beeps at me.

So I can work around this by selecting text in the message, but it’s a few more keystrokes and I like the old behavior for enabling me to process mail quickly with less shifting between keyboard and mouse. Any way to enable the old behavior?


You’ll probably find that the update to EC has disabled the Omni Clip-o-tron - updates routinely do this as a safety/security measure. You may have seen a message “Incompatible plugins disabled” or similar.

The solution is to reinstall the Clip-o-tron. More information here:

Mail disables clip-o-tron

I don’t think reinstalling is the solution for EricJ as he is able to use it by first selecting text in a message.

In my experience, the clipper works if you either select text inside a message, or explicitly select the message itself in the messagelist. Try it: even although you are looking at the message content at the right, click it once in the list to the left and try the clipping-shortcut again.

You might be right. However, my current setup:

  • Had the “incompatible plugins” message
  • Works as EricJ describes. If I select text in a message, the clipper appears in my Services. If I simply select the message in messages pane, it doesn’t.

Note that I can’t reinstall the Clip-o-Tron on this device - I’m on a Sierra beta - so I can’t check that a resin tall still works. However, it worked fine under El Capitan

Yes, reinstalling the Clip-O-Tron was the solution - sorry I didn’t realize this right away. I somehow had in my head that the Clip-o-tron had been completely deprecated, but after reinstalling it, all works as before. So the behavior I describe above is what you get from the OmniFocus system service without the Clip-o-tron (which is nice to know that you still get some functionality anyway).

Thanks for the quick help,