Current editing date granularity, possible to set to hourly?


#1

Hello! New to using OmniPlan so I might possibly be asking for something that doesn’t gel with how OmniPlan is supposed to be used. But…

I have a few tasks that will take a half day’s effort, I can’t seem to mark these as complete until tomorrow though because if I try to level the project, tasks from later fill up the time I’m setting as completed on another task. I have levelling set up to not schedule anything before ‘now’, but it seems like ‘now’ is just the date, ignoring the time. So everything ends up at 9am if I set things as complete. Setting the current editing date under Project only lets me set, the date, no time option.

Sorry if that’s a bit of word salad, it’s kind of a weird issue to articulate.


#2

With hour AND MINUTE we could model batch windows.

THEN I’d buy OmniPlan.


#3

Not sure if I understand your problem properly - but if you schedule in hours rather than days, does it make a difference?


#4

The issue is more about levelling than anything else. If I set an item to complete, auto-levelling kicks in and treats that completed time as time that’s now free, and fills in with other tasks. That wouldn’t be so bad, but in this case, it’s filling up the plan, in the past! Like it could be 11:30am, if I mark a task that started at 9am as complete, OmniPlan will reschedule stuff for 9am, that morning! In the past! My best guess as for why it’s happening is that OmniPlan’s concept of ‘now’ is only as finite as the date, and not the time. So even when you check the option to prevent levelling from booking in tasks in the past, it still does if it’s on the same day.


#5

OK - I get that. I think you should raise a support ticket with Omni, because (I could be wrong) that sounds like a bug to me.

If you compleet a task with auto-levelling set, the changes should only take effect from the time the task was completed - which is what you expected?


#6

Not 100% sure if it’s a bug, seems to happen on the iOS version as well, which makes me think I’m using OmniPlan wrong somehow. Seems like if I give every task a constraint of some kind, either a time/date or a prerequisite, the tasks stay where they should, but obviously there’s a lot of times where I could have a few things that don’t need to be done in any specific order, but should be levelled so they’re not being done all at the same time. Will still put in a bug report though, thank you!


#7

@toish It can never hurt to let our Support team know about an issue (even if you’re not sure if it’s a bug!). We try our best to keep an eye on our forums, but email is the best way to make sure your feedback makes its way into our development database.

In this case, I’m pretty sure this behavior is a bug - it looks like this leveling behavior changed between OmniPlan 2 and OmniPlan 3. We’ve had one other person report this issue, and I’ve added your comments to their report. We’ll look into addressing this in a forthcoming OmniPlan update!

For the time being, I’m really sorry for the inconvenience that the current leveling behavior causes you!


#8

Perfect thank you! Will keep in mind to email first! Hasn’t been much inconvenience at all though!

For any one finding this thread looking for a solution in the interim, just level, then connect everything via F>S prerequisites, by resource. Leveling with out any completion works fine, so it’s just a matter of linking all of Resource X’s tasks together, Resource Y’s tasks together etc.