Dates are horribly wrong in several non-US date formats [A: Omni is investigating]

I have just installed omnifocus 2,
It looks great but when I tried to adjust a due date of a task,
whatever I did, it alwas went to 05-05-05

Even existing tasks with existing due dates.
when I click on the due (or defer to) date in the inspector, the calendar shows 2005 and when I click and click and click etc on the month-triangle until I am in 2014, and press the right date there,
it goes back immediately to 2005

this is really horrible.

My system settings are language and region Netherlands (custom)

aparently this messes up omnifocus2.

is there a way to change the date formate in omnifocus2?
I cannot find it.

I have also turned the computer off and on again, this did not help.
I am out of options here.

anybody recognises this?


OmniFocus 2 uses the system date format. Could you post a screenshot of your System Preferences date format?
For example:

1 Like

I found a similar issue OF2.

I typically use an ISO like format “yyyymmdd”, which totally confuses OF2. I experimented with other formats & found that using anything too much beyond the default is problematic. So setting up the short date in System Preference as 2014.0524 renders 2000.1231 in OF2.

This was not an issue in OF1.

Any help appreciated.

I just downloaded the public official 2.0 release, and am having this same problem. I am able to enter dates in the main outline, but the Inspector only shows 5/5/14 5:09 p.m. as the Added and Changed times, and anything I enter in the Inspector gets changed to 5/5/14. The +1 day / +1 week / +1 month buttons likewise do not work. It’s as if the Inspector pane is stuck on the date 5/5/14.

1 Like

glad to hear I am not he only one with this problem. I circumvent it now by not entering or changing dates in the inspectorpane, but this is silly really, because that is wat it is for, sort of.

I would like to add a screenshot, but it says "sorry, new users cannot upload attachments’.
you can find the screenshot here: [link removed]

the problem is getting worse now, when I set a due dat not in the inpsector pane but in the item (to the left of the circle) it changes, seemingly at random, to a different month and a different year. Not 05-05-05 anymore.

I have not been using OF2 for a couple of days, only the ipad version is usable now for me :(
But I see the problem has not been solved. Will I have to go back to OF1?

I was having the exact same problem as you! ( WHY ALWAYS 5/5/05???!!! ) I am in French(custom) region. In fact, I saw your post which let me know I wasn’t the only one.
I then went to my language/region-> date section as you’ve shown above. I dimply deleted everything from my “short” group. then i proceeded to rein put (for me was day: day# / month# / year#, to get “th:12/6/14”) and after i saved my settings and retried OF2, it worked! now all my dates are fine.

I don’t know if it will work on everyones, but it’s a pretty easy fix if it does. good luck!

1 Like

@liesbeth Can you reproduce this craziness with the standard Netherlands/Dutch date format, or only with your custom one? I only see it when the weekday is added before the date.

1 Like

@lizard I can tell you that mine only seemed to break when I tried to add the weekday (which I do in part to solve another problem, the lack of the Due Date drop-downs)

But it looks like @rundafhein has found the only date format that can handle the weekday: WD:mm/d/yy (where WD = two-letter weekday). I’ve tried various other combinations, to no avail.

There is one more problem when using system date format. Previously when there was no integration with sys date format I used to use english names of DoW and close days e.g. next Sunday or tomorrow or Monday or next week etc. Now I can use native language names like понедельник, вторник, среда (in russian) etc. but still I have to use english “tomorrow”, “next week” or even the mixture of “next вторник”. I need either an option to disable usage of system date format or a full integration with native language words in such a way when I can use all russian, german, french or whatever else words depending on system day format.

@91koff This sounds like a separate issue, which we’re aware of. This is a consequence of not having localized OmniFocus 2, which is now in progress. Thanks for your patience.

1 Like

I got this advice from Omnifocus support:
this is an issue that we discovered at the very end of the development of OmniFocus 2.0 so we couldn’t fix it in time for the release. We’re working on a fix for the next update, but for now the workaround is to set your region setting to America and that should allow you to change the due date of a task. I’m very sorry for the inconvenience this causes!

I did that and now I have to use comma’s for thousands separators and dots for decimals, which is the other way around in Dutch. But otherwise I’m fine ;)

@lizard Should I create one?

@liesbeth Thanks, but the problem is that America locale and Russian are quite different at the scale of th whole system. This is not an option for me. As I mentioned before It would be great to have an option to choose what locale to use inside Omnifocus either English or the system one.