Defer and due times not sticking

Anyone having trouble with defer and due times not sticking?

When I enter a time in either the task itself, in the inspector date/time box, or via the calendar pop-up, it doesn’t stick. Instead, it reverts to the default. Is anyone else having this issue?

FYI - I’ve submitted a bug report about this days ago. Just wondering if it is just me or…

How exactly are you specifying your dates? Using the calendar or typing in text? If text, what exact text are you entering? Are you making sure to hit Return after typing in a date?


In the latest built, I’m not able to enter defer and due dates via the keyboard using words. Numbers work. If I highlight the field and try to enter, say, “today” it doesn’t do anything. If I enter 6:15 pm it does work.

Hmmm, things like “tod” for today, “tom” for tomorrow as well as their extensions are working properly in the main task area and quick entry. The area in the inspector at the left is not accepting letters in these areas at all. Supposedly that:

  • either is an omission still to be implemented
  • or is thought to then have the calendar picker as means of least friction

I noticed this the other day when I had a task deferred until 12PM and wanted to set it to 12AM. I ended up opening OF1 and changing it. I’m not seeing it in the latest build anymore though.

Kyle S - I am entering times both ways:

When I type it into the inspector - for example, selecting 3 in 3:00, and typing 15 (my sys default is 24 hr clock), when I hit return, it pops back to the default defer time.

When I open the calendar and type the time in, it looks like it sticks, but when I select the action, it is still the default.

When I open the calendar and use the up and down buttons for time, same same.

I had a similar issue in OF1, except that the calendar buttons worked. But they were the only thing.

  • when entering times use “15:00”, otherwise it could also be a date…
  • when using the calendar, enter the time and acknowledge by pressing return, that should work fine then

… generally, always use return for ending entry, this works perfectly fine as of 208312

This broke and should be fixed again as of yesterday’s builds. Sorry!

I’m on build v87 r208322 and it is still not working. Yes, I am entering times in 24hr format and yes I am acknowledging with an enter. Any further thoughts?

Sorry, I’m unclear.
I was specifically referring to the inability to type letters into inspector date fields as being broken and fixed.

What is still not working?

I moved a post to an existing topic: Dates are horribly wrong in several non-US date formats [A: Omni is investigating]

I am having the same problem - please note that the problem is not with DATES, but with TIMES entered. A task may currently display a date and time in the Defer Until field. I then change the TIME in either one of two ways:

By deleting the current time displayed and re-entering/typing a different time in exactly the same format, OR
By clicking on the calendar icon next to the Defer Until field and changing the time by clicking the arrows

In both cases, upon hitting the ENTER key after the change, the time reverts back to the CURRENT TIME on my System. Note that it reverts to the current system time, not the previous time that was displayed,.

Any thoughts?