Deletion Hell Narrowly Circumvented

This is what I sent to support. You can call me a scholar or a fool but my anger overfloweth.

Last night I entered multiple tasks and updated tags.

The updates synced from OF3 Mac to OF3 iOS.

The OF 3 iOS app doesn’t create backups immediately when ever it syncs with the server or updates are made in app like other similar apps.

It only creates 1 backup every 24hrs.

So I have to remember every time I work in OF3 Mac and go mobile to OF3 iOS to manually create a backup to include those changes.

I see no option to force OF3 Mac to backup manually instead of waiting for the algorithm whose time interval is to long. To make sure my backups contain the latest updates and changes in the future.

A colleague, she fell onto me, which resulted in my phone being knocked out of my hand.
Attempting to grip it, my fingers slid across the screen and deleted some items.

There is no trash can, no dual stage deletion for example a dialog box asking to confirm and undo, redo don’t show what they are doing.

Every single element can be deleted in one swipe on OF3 iOS and one button on OF3 Mac. From top level folders containing multiple projects, to single projects, action groups, single tasks and even tag groups and tags.

Back to today…

Since I have no way of telling what I deleted. I have to reload a backup…on OF3 iOS I go into backups and the backup is 24 hours old not including the changes that already synced from OF3 Mac.

Now I have to wait the whole day until I get back to my Mac to see if the last automatic backup there consists of the changes and updates I made last night.


Just got back to my Mac hours later, I had to wing the entire day.

OF3 Mac last database backup was at 2:53pm, I was at my system from 1pm until 8pm. So the backup didn’t contain my latest updated and changes.

After careful digging, I realized that for some reason the deletions on OF3 iOS made this morning hadn’t synced to OF3 Mac. (Not sure why, figured if it worked as it should have, it would have synced)

So I replaced the database in the server with what’s on my Mac and then replaced the data on iPhone from the server.

I was lucky the deletions didn’t sync from OF3 iOS to OF3 Mac this morning or I would have lost damn near 15 complex projects with flagged and high priority tasks. So I have to thank a failure in operation for the recovery of my data.

All this god damned garbage because your wretchedly arrogant developers won’t listen to customers and create a simple trash can, nor implement any of the other blasted suggestions they have been pleading for, for YEARS… YEARS!!!

Countless forum posts from many intelligent users who were able to spot this ridiculous and dangerous deficiency almost immediately upon use. Three generations later and it still has not been addressed.

It should NEVER be this easy to delete items from a piece of software that aspires to be the foundation from which we plan, manage and execute projects and tasks that relate to all facets of our lives.

Many won’t encounter this trial but for those who did and will in the future. The consequences are disastrous and the data redundancy methods cumbersome and flawed.

I will no longer use this software nor recommend it to anyone until this egregious oversight is rectified.

END of email.

I was acutely aware of this flaw and was always especially careful. I decided to stay with OF due to the investment but this experience was a wake up call as to just how close I am playing to the fire.

I need to find an alternative as this exceeds my risk tolerance.

Thank for reading.

Sorry to hear about the trouble. I’ve experienced the uncertainty of not knowing which items I’ve deleted—it can certainly be angering!

There might have been a simpler, hidden solution to the issue, though: Shake to Undo. I just tried it on one item. You’re right, you can swipe across the screen and delete an item—but if you did so accidentally, shake the device for an Undo prompt and you can backtrack.

Hey Ryan thanks for replying,

You see… after we both got up, by that time my phone had auto locked,

I was actually using the phone and moving projects into folders while it happened, when I picked it up and re authenticated to unlock OF3 I was presented with the home screen. I went back into the project folder I was working in added some tags etc, however, only after perusing my projects did I realize that a folder containing projects was missing.

At that point I would have had to shake to undo quite a few updates, I didn’t want to do over EVERYTHING I had just done.

Undo/redo also do not work if the app is shutdown and re opened or re-authentication is required, also,
If I enter a different view from where I made a deletion and hit undo I will not know that something was actually undone unless I know exactly what I deleted (or changed) and I go back to check that same location, nothing logs these changes. I know you are simply offering what solution is available, however, as far as solutions go its an extremely poor one.

Every other task manager has a trash can or multistep delete except this one… it is just absurd.

Do you know that there are forum posts dating back to 2009… 10 years ago with customers requesting this. So I doubt it will ever happen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.