Export to Keynote error: This presentation can’t be opened because it’s too old

Exporting to Keynote. Keynote says “This presentation can’t be opened because it’s too old.”

Help please.

Thanks, Scott

Hmm. I tried to export a simple outline and received the same message. Error dialog shows the following:

Running OmniOutliner 4.1.4 and Keynote 6.5.2. I have an old copy of Keynote that I could use if pressed, but this has to be a bug. I’ll file a report via the in-app support messaging.

Hi there,

Sorry for the frustrations! We would like to add support for the new Keynote file format in the future, however implementing this support has proven quite tricky as Apple has not documented the new file format. We’re looking into our options though, and I’ll attach your comments to our open request for this functionality so that the OmniOutliner team is aware you’d find it useful as well!

In the meantime at least, another customer from our online community has created an AppleScript that can be used to export from OmniOutliner 4 Professional to Keynote. Hopefully this offers an okay workaround for you in the interim! You can find that here:


Sorry for the trouble this causes you! If you have any other questions or suggestions, please don’t hesitate to get back in touch. We really appreciate your support!


Anne J.
Support Human
The Omni Group


I have been using this script for a while now and it is very useful but I think the most recent version of OmniOutliner broke it. tried it several times and it crashed my copy of OO.
Would be really good if someone could look into this. I sent two or three crash logs to Omni and said what the cause was, dunno if that will be looked into, I know it’s a small point but it is a useful one to me and some others too I suspect.
All the best…

Have you emailed support about this? Or do you have a ticket number for your crash reports I can look up? Thanks.

Just tried it again and exactly the same result - it crashed the app. Sent an email and said it was exporting to keynote. Will try now on a new outline and see if that changes anything

Sadly, it still causes a crash with a new file. I put in the keynote cause on the dialogue with a bomb on it and then also on the email. Hope this helps solve this as this is a very useful feature for me…

Found a ticket in email, here is one from 22nd 'Thanks for sending in your CrashCatcher report! This report has been
assigned an ID of [OG #1359282]

Ah, that’s a toolbar bug with trying to run an AppleScript from either the overflow menu or when the toolbar is in text-only mode. You can either move the script so it’s visible on the toolbar and showing an icon or use the new test builds that have fixed this. http://omnistaging.omnigroup.com/omnioutliner-4/

Great answer, thanks! Should have noticed that, and it will save a load of time in work arounds, thanks

There is now a PowerPoint exporter in the 4.3 test builds if you’d like to give that a try. It is available for standard and pro users.