Exporting to Excel


OmniOutliner is great for inputting and organizing data. But sometimes I need to export it to Excel. Is there a best way to do this?


Me too was thinking of this since OO is a kind of spread sheet just like Excel
It would be natural thus to export or import from Excel.


A csv export option would be very helpful to work with Excel on some of the outlines created.


CSV import would be really good too


Exporting to CSV would be very helpful to move simple project outlines, or schedules to other formats I could easily share with others


I agree CSV export would help.

I’m new to OO, isnt’t there some ‘features requests’ list to be voted anywhere?



Omni is an awesome software developer but they are not known for regular app updates and feature improvements. They still haven’t update Keynote export to work with the latest version, for example (it only works with Keynote '09).


Wanted to addd to this I find sharing my notes is a challenge. An export to CSV in plain text would be helpful for project outlines etc.

For Keynote export there is a script that works


No there isn’t, the latest version of Omni Outliner breaks the script - really annoying


The script still works for me. What errors are you encountering?


If you have OmniOutliner Pro, you can add a CSV export with this plugin pack.


doesn’t work. there’s a html-import error when trying to open the exported file with Excel. error-message: "The file you are trying to open is not a valid Excel XML Spreadsheet…You can open the file as text in Excel.

Which is not hugely useful.


Sounds like you used the Excel XML export not CSV. That Excel export uses the first short lived xml format. Though it works with a sample document I tried Excel 2011.


export to csv works
import in Excel results in an Excel sheet with text - no columns



What version of Excel? Can you send a sample OmniOutliner document to omnioutliner@omnigroup.com so I can see what’s failing? Thanks.


As an alternative, export as ‘Plain text (with tabs)’? The resulting file should have an extension of .txt (which it should get by default). Excel 2011 has zero issues importing a tab-separated text file and keeping the columns. Note… you’ll still need to run it through the Text Import Wizard (happens automatically) but unless there are some oddities in your text, just hitting return until it’s done should suffice.


What am I doing wrong? I put the plugin file creating the required folder but I don’t see the Excel options.

Here is a screenshot


I can’t tell from this screenshot if that’s the correct location but, you should be able to double-click on the .ooxsl file and it will install itself to the correct place.


The location is shown at the bottom of the screenshot, but never mind, double clicking solved the problem. I had manually put it in there before, I didn’t know I was supposed to double click it. Thank you very much :D


Ah, haha, I bet I had my cursor over the image while pouring over it so it was hiding that part :)