Find and replace

In OmniFocus 2 for Mac, when I try to do a find-and-replace on a search string, I can find the string but can’t replace it because the buttons are greyed out. Am I missing something?

1 Like

Having the same problem; some context for clarfication.

I use some projects as “templates” for future projects (complicated projects I start once every few months, so the steps are tasks saved as “PROJECTNAME : task”). The Find & Replace feature used to be great for this.

Now Find will still get the next instance of PROJECTNAME (once a task is highlighted), but Replace options are greyed out.

It gets really weird if I click to edit the task. Then the Replace options are no longer greyed out. But “Replace” actually just PASTES in the text from the “Replace With:” field! So if the cursor is between the J and the E in PROJECTNAME, with search string “PROJECTNAME” and Replace With “my cool project”, the output is PROJmy cool projectECTNAME.

Right now, manually pasting is significantly more practical than Find and Replace.

Filing bug report with support@omnigroup.


This used to be a useful and reliable feature of OmniFocus. Thanks for reporting the bug; I tried but am not sure my email got through as I didn’t receive the usual acknowledgment.


I am having the same problem too. As dwhs explained, the “Find and Replace” feature was very useful for leveraging the power of project templates. I also will send a note to OmniGroup as a bug report. Hopefully this gets fixed soon!

1 Like

I just raised a request to the omnigroup support team to fix this issue (message id = OG #1226036). I will update this thread with any feedback I get from them.

Here is the reply from OmniFocus Support:

“Sorry for the trouble here. What you describe is a known bug — currently the Find & Replace options only work in the Notes field, not the main outline. I’ve added your report to the open bug ticket in our development database to let the rest of the team know you’ve run into this, too. Hopefully we can get that bug squashed in a future update, and my apologies for the inconvenience that’s been causing in the meantime.”

Was this ever resolved - I’m still not able to do this outside of notes field.

1 Like

Find and Replace (cmd-f) seems to work ok when the MOUSE focus is in the main visualization panel showing the projects and actions. In this case the scope for find and replace is whatever is available through the panel. In omnifocus 2.8.1.