Fixing effort and duration and resource calculations?

Hi guys,
I hope someone can help. Me and my dad have started working together. Our company builds houses and I downloaded omniplan to help with the project tracking of the developments. Everything was going well until I started to add in our resources- were not the best with programs by the way! for example: I added all the tasks in for the project with an accurate time line and dependency schedule with the task cost. When I went to add in resources - e.g. 1 man and 1 machine is €45 per hour, it did not multiply the 45 by 16 hours (2days) only by one day and shortened my project timeline which I did not want to happen as the timeline I have set out is correct! I also assumed that if my effort said 2 days then the resource per hour would be multiplied by this?

Thanks in advance for your help :)

@Shan_f It sounds like you’re running into trouble with OmniPlan’s resource allocation in your project. It’s hard to say without looking at your file, but I’m guessing that one of two things is happening in your project:

  1. The efficiency for your equipment resource is set to 100% in the Resource Info Inspector. If your equipment doesn’t help the task be completed more efficiently (in other words, assigning the equipment to a task doesn’t help the task complete more quickly), you’ll want to change this value to 0.

  2. The Resource Allocation option currently selected for your tasks in the Task Inspector does not match your desired scheduling workflow. More information about resource allocation is available in this section of the OmniPlan manual:

Does this help explain the behavior you’re seeing? If not, I’d recommend contacting our Support team so that they can review the scheduling behavior in your file with you. They can be reached at If you’d like to troubleshoot this issue over the phone, Support can be reached Mon - Fri, 10am - 5pm Pacific at 1 (800) 315-6664 or 1 (206) 523-4152.

Thanks for your reply :)

When I try to change the value to 0% it says it must be at least 1? Can you help with this?

I got it to 0 but now when I try to add the resource to a task it won’t add at all?