Flow of cursor control is wrong on Clippings

At least in my opinion. When I clip an email, for example, when the quick entry window comes up the email body is the note of the task, which is great, but the note is highlighted and that’s where the cursor is placed. When I try to shift-tab to go to the title so I can modify it appropriately (defaults understandably to the subject of the email), nothing happens, the cursor doesn’t move. For me to change the title I have to actually move the mouse to that field and click. Very inefficient. So I have basically a couple problems with how this works now:

  1. In my opinion, cursor control should not be in the note, it should be in the task title, with full keyboard control to let me tab through the various fields so if I want to get to the note I can easily do that.

  2. If you insist on putting the cursor in the note field (which makes no sense to me, but perhaps will to others), at least give me keyboard control so I can reverse tab to the title field.

the way it works now just doesn’t make sense to me on any level. Perhaps it does to someone else.


100% agree with this and also created a ticket about the issue. It should always default to the subject of the todo and not the message body. Worse is if you hit tab it just clears out the text of the clipping, there’s not shortcut to move to the subject.

Command-quote doesn’t work to move to the title?

lucas…cool, yes it does. Didn’t realize that behavior was present.

I still think that immediate control should go to the title of the task and that I should be able to just start typing, and then let me tab to the other fields of that window. Make me use command/quote to move to the note field, not the other way around. I’d think that the majority of the time people clip something, they’re not editing the note, they’re editing the title.

I, too, agree that the current behavior should be changed.

Yeah came here to say command quote works, but still seems unintuitive to have it first select that note field and then having tab erase said field is really really bad UX.

just confirming that the latest beta I installed this morning fixes this issue. Clip an item and the subject line is highlighted with cursor control, not the note.

Thanks OmniFocus, I really appreciate you getting this fix in!