How do I clip email items to the Inbox in v2?

One feature I’m really missing in the current beta is the ability to send the mail item (selected in the message viewer) to my inbox for future processing. The link to the original email is critical of course given that future action might be required with that email item.

1 Like

With this morning’s build, you should be able to use the “OmniFocus: Send to Inbox” service once again.

also for Outlook?

Somehow I’m not seeing this. When I select an item from the message viewer, I don’t see any service. I know I have to send to OF checked under service preference. If I select a text manually within the email, I do see the service, but that’s not what I was referring to above.

Send to Inbox should work from any services-friendly app when you have text selected. (I don’t have Outlook handy to check its behavior.) There was a specific bug with Mail that Ken’s referring to.

‘Send to OmniFocus’ has only worked with selected text. The Mail Clip-o-Tron 3000 is not currently in OmniFocus 2, but you can re-install it from OmniFocus 1 and it should work.

Thanks, works with outlook

I just tried this, and the system is getting confused, and then sending to inbox is actually starting OF 1 instead of sending it to OF2. I think I’ll just use select text and send for now, and wait until the proper support is implemented.

I moved 3 posts to a new topic: What does a "Error compiling handler script” error mean when clipping?

I had to disable the OF 1 behavior and activate OF 2 and assign a keyboard shortcut under System Preferences > Keyboard > Shortcuts > Services > Text.

Works a treat.

not sure what you mean exactly by ‘re-install it from OmniFocus 1’ - do you mean re-activate it in Omnifocus one clipping preferences?

Can anyone have luck with The Mail Clip-o-Tron 3000 worked with OmniFocus 2 ?

My experiments:

  1. Installed OF1, Activated The Mail Clip-o-Tron 3000 and assign Shortcut
  2. Rename OF1 app to OmniFocus1
  3. Installed OF2
  4. Disable Shortcut for OF1 in SystemPref and Enabled Shortcut for OF2

Result: All still emails drops to OF1 database :frowning:

Can anyone provide short instruction to make The Mail Clip-o-Tron 3000 worked with OF2 ?

BTW Clipping from other apps (for example Safari) works great, and Tasks created in OF2 Inbox.
But The Mail Clip-o-Tron 3000 still adding tasks to OF1 Inbox with same shortcut

Here are the steps I followed, which worked for me to activate the Clip-O-Tron in Mail connected to OF2, rather than OF1:

  1. Make sure OF1 is not running.
  2. Starting from the Preferences–> General panel in OF2, set up a new shortcut in Keyboard --> Services–>Text to Send to Inbox (i.e., not the same key combination as used in OF1).
  3. Turn off (uncheck) the shortcut for OF1.
  4. Quit OF2.
  5. Open OF1, Preferences–> Clipping and activate the Clip-O-Tron with the original OF1 keyboard shortcut. When it asks to restart Mail, agree.
  6. Quit OF1.
  7. Open OF2.
  8. Go to Mail, select a message, use your new OF2 shortcut for Send to Inbox.
  9. Watch productivity soar.

Good luck. That’s what worked for me, but of course YMMV.


This may be because Clip-o-Tron is an AppleScript and may be getting confused by having 2 “OmniFocus” apps on the system, see this thread: Migrating and using AppleScripts

Clip-O-Tron is not working for me, either. I had the Mac App Store version of OF 1 installed. I removed it completely, and even went so far as to clean its traces out of ~/Library. I then grabbed the downloadable OF 1 and installed the Clip-O-Tron from there. Here’s what I see:

  • With OF 2 running and OF 1 removed, Invoke the service from, either via shortcut or directly from the menu.
  • Watch pause for 10 seconds or so. The “Mail” menu remains highlighted in the menu bar.
  • Nothing else happens: no OF 2 clipping window ever pops up.
  • In Console, I see:

3/27/14 4:22:28.688 PM[1025]: Application com.omnigroup.OmniFocus.MacAppStore never opened its Services port before the timeout.

So, it looks like somehow the service is still trying to send the clipping to the Mac App Store version. I’ve looked where I can, and can’t figure out what’s still pointing to the MAS version.

FWIW, clipping from all other apps that I’ve tested works fine.

EDIT: works now after a reboot. D’oh!

Worked for me. Thanks!

Otherwise, I recommend the “mail drop” feature. Thanks to automatic syncing it’s very fast and convenient.

The problem with Mail Drop is that it doesn’t include a link to open the original message in Mail, something I use daily when replying to emails.

Correct. It only shows the contents, not the link.