How to cancel editing the current task title? (Escape key doesn't work)


When I’m finished typing the title of the task, how do I save it and return to selection mode?

I need this, for example, after I’ve entered 4 tasks to get back into selection mode select these tasks and connect them finish->start. All of this can be done from the keyboard, which is awesome, but I can’t transition from the edit state to the selection state after the editing has begun.

The Esc key doesn’t help. And the Enter key creates a new task.

Right now, I have a workaround – press Enter to create a new task, then press Cmd+Z twice to delete it – this gets you back into selection mode, but hopefully there is an easier way. Is there?

@miked It sounds like you may need to uncheck this option in OmniPlan’s General Preferences:

Does this result in the behavior you were looking for?

Still, why the escape key doesn’t work? What is it supposed for in the context of editing a task?

Is there a way to toggle editing on when you’ve got a task selected without using the mouse (like OmniOutliner)?

@macdork I think command-return should do what you’re looking for!

Thanks! There used to be a .plist setting that allowed escape to function this way; does that still exist?