How to go to the search field

I’m using OF 2 on a Mac. I’d like a keyboard shortcut to be able to quickly type something in the search bar without having to us my mouse to get there. In OF 1, it was CMD, OPTION F. When I look at the EDIT menu, it suggests that it should work if I typed in OPTION, CMD F. That doesn’t work for me.

On a related note, I’m wondering what the difference is between going to the search field (upper right corner of the screen), and using the FIND option from the EDIT menu. Could someone explain the difference please?


Odd. CMD-OPT-F works for me in any perspective whether I have a task selected or not. I haven’t tried that key combination before (thanks for pointing i out) but I did just update to 2.0.1 (non-MAS) before I tried it out.

On your related question, I just read the following in the excellent iBooks OF2 manual:

“Another way to locate a lost item in your current view is with the find dialog (Command-F). While search narrows what you see in the outline, the find dialog looks through all the fields currently visible in the main outline and highlights results instead, providing a setting for them which you can browse through until you find what you need.”

Excerpt From: The Omni Group. “OmniFocus 2 for Mac User Manual.” iBooks.

Is the find dialogue working? When I do CMF-F, the find window appears, but when I enter a search string nothing is found, even though ALT-CMD-F does find it. I wanted to do a search and replace but can’t because the find function seems to be disabled.

Interesting. I just opened up a Contexts Perspective, did a CMD-F search with nothing highlighted in the main outline window, and got an error beep. It found nothing.

So I highlighted a context, and the CMD-F search worked.

Then I clicked on the Context Perspective in the sidebar to remove the highlight in the main outline window, and this time the CMD-F searched work.

Strikes me as a bug.

Ahh, now I see what the OP meant. I confirm rogbar’s findings on my machine. I sent a bug request via the Help menu.

I just found out my problem. I was using a different piece of software that ran in the background on my computer. It had a shortcut that used the same keyboard combination. I disabled that software and now my omni shortcut works. :)