How to type two hyphens in a text shape?

When I type two hyphens (U+2010) in the text of a shape, they immediately disappear and they are replaced by what seems to be an en dash (U+2013).

Obviously I don’t want that. If I wanted an en dash, I would type an en dash. How can I deactivate that behaviour? Thanks in advance for your help.

Does this help

1 Like

Funkydan2, thank you very much for your help.

Adding a rule to replace “–” by “–” in System Preferences > Keyboard > Text unfortunately doesn’t work (I use Mac OS 10.10.5). Quitting & reopening Omnigraffle didn’t help.

The other solution, Edit > Substitutions > Show Substitutions > deselecting Smart Dashes doesn’t work either because there is no such menu in Omnigraffle. Strangely enough, Apple only gives this same tip (

But I think I have found a workaround: switching to the Unicode Hex keyboard and entering the hyphens with the Alt-2010 combination keys. This trick seems to work, it survived both printing and quitting & reopening the file.

Thank you for this answer. I do notice a slight shortcut - you only have to use the unicode to type the second hyphen.