iCloud calendar spam in forecast

Hey everyone,

So over the last couple months I’ve been getting icloud calendar spam in the form of event invites. I declined all of them and my calendar app doesn’t show any… but when I go into forecast on omnifocus, all of the spam shows up. How do I get rid of this?

It should be noted that I started using omnifocus a week ago and haven’t gotten spam since setting up. So everything is from before setting up omnifocus.

Thanks in advance!

So this isn’t exactly the easiest fix but I just decided to create a new calendar and moved all the events I wanted to keep to the new one and deleted the old one. Problem solved but that could be a serious task if someone has this problem with a full calendar.

Look at this article:

Use Option #4. This will change the calendar invites into e-mails that will go into your iCloud e-mail. It will be safer to delete junk invitations.

Apple seem to have fixed this for now, so you may be OK.

I had this issue for a wheel and, following a tip from elsewhere: did this - it may help if the problem recurs

  1. Create a new calendar called Spam (or similar)
  2. Move the garbage to Spam
  3. Delete the Spam calendar
  4. Go to iCloud on the web and in calendar settings, change the way you receive invitations. Calendar/Settings/Preferences/Advanced and choose Receive invitations by email. That way the spam never gets into the calendar