Inside OmniFocus feeds show old entries as new


#1

Every few weeks or so, the Inside OmniFocus site includes as new a bunch of old, and often outdated posts.

Today I got this in my RSS feed

https://inside.omnifocus.com/applescript

It’s an article on AS support in OF2.

If you’re gonna recycle material at least update it a little.


#2

Thanks for letting us know about this—I’m pretty certain it’s not intentional. We’ll investigate, but it would also be great to know what RSS reader you’re using in case we’re doing something that’s only affecting certain clients.

Edit: Also, it would be helpful to double check that the feed URL you’re using is https://inside.omnifocus.com/blog/feed/.


#3

Thanks - it’s happening with NewsExplorer on ios and Mac but I’m pretty sure it was also happening with Feedly before I switched earlier this year.

The URL I’ve been using is http://inside.omnifocus.com/feed - not sure where I found it or if it was suggested by Feedly.

I just added the http://inside.omnifocus.com/blog/feed and it has a different set of new entries but it includes one that’s a year old as new : https://inside.omnifocus.com/blog/around-the-web-august-2018


#4

I haven’t looked into the actual feed generation but it looks like at the very least, the entries don’t have publish dates, which is likely to cause problems. Sorry that these aren’t more useful at the moment.


#5

FYI: 14 of the Inside OF Blog posts showed up as new again today,


#6

Just in case this matters, this isn’t happening for me. I use FeedWrangler as a back end and fiery feeds as a client. What do you use @dfay?


#7

Thanks - it’s happening with NewsExplorer on ios and Mac (icloud sync) but I’m pretty sure it was also happening with Feedly before I switched earlier this year.

This is the only feed of a couple hundred with which I’ve seen the issue.


#8

Same 14 posts reappeared as new today.