Is this a bug? (collapsing on iOS - opening on Mac)

So I have a list on iOS and I collapsed the list there. When I opened the doc on the Mac I was instantly confused when focusing from the sidebar - most of the info from the list was hidden. Is this normal behaviour?

Actually I guess not because I can collapse and expand on the Mac… then it shows in the sidebar.

Question then is: how can you tell if you’ve collapsed part of a list, and it’s hidden when viewing from the sidebar? I feel as though it’s possible to accidentally hide something and never know…

Hi, I’m not sure if I’m following your description so sorry for any unnecessary explanation.

The section list (what shows in the left sidebar under the Sections tab) should always show every level 1 row. Just like the main outline view, each row in the section list can be collapsed. This is indicated the same way as it is in the main view with the direction of the disclosure triangle.

When you say parts are hidden in the sidebar, was this due to some parent row being collapsed in the sidebar? Or were sections actually completely missing that reappeared when you toggled the expansion state of a different section?

Honestly, I have no idea now. I may have gotten confused by how it works.

Here are my two problems - in the section list, if everything is expanded, there’s no easy way to select the whole document. In a short list I can click at the bottom and the whole document is selected. In a long list, I can’t do that. This is a problem if I need to select all of my main list (for example, to expand it).

Secondly, it’s confusing when hiding rows. How can I tell if something is collapsed? (ie: hidden - they just seem to vanish) I can’t find a way, and for some reason the collapsing action can’t be undone.

I’m going to assume you’re using v5, as not all of my answer will apply to v4.

By “whole document is selected” I take it to mean you want to see everything in the main outline view instead of being focused on just a part of it. You can achieve this by clicking the Unfocus button in the bar at the top of the outline view.

You can also use the Unfocus command under the View menu or it’s listed keyboard shortcut.




Expansion state is indicated by the disclosure triangle. When the arrow is pointed to the right, it’s collapsed. When it’s pointed down, it’s expanded. In the below example, rows “Total” and “2016” are expanded. “November”, “December”, and “2017” are collapsed. The same indicator applies to the main outline view.
50 AM

Thanks for the reply, but no… I don’t mean the unfocus button.

Here’s a simple way of explaining the issues - can you click at the bottom of the left list if it’s very long? The answer is no. There’s no room below it. Clicking below allows you to deselect any chosen items in the left list. You can’t use deselect from the menu - it doesn’t work. You can only click at the bottom of the left list if there’s room. That’s a problem.

Secondly, if I collapse items in the main list they are effectively hidden. They simply vanish. There’s no way to tell if items are hidden. This is a big problem.

Derek, sorry just to clarify… with the template I’m using there are no disclosure triangles on the Mac…

I still don’t know if you’re using version 4 or 5. Versions 4 won’t have the unfocus button. Regardless, in both version, the left list is the section list and looks like the screen shot in my previous reply (It has the heading of Contents in v4). When you select an item in the section list, that is the same as using the Focus command on that row. Clicking below all items in the section list is the same as using the Unfocus command. You might need to use the Unfocus All command if you’re using version 4. If you do not see the same result when unfocusing [all] as clicking below the list, a screen recording would help a lot. Please email support to further dig into this if needed.

Are hidden disclosure triangle what you want? Or would you like instructions on how to make them visible?

I’m on version 5… I mentioned the unfocus button in an earlier post. I understand how the selection list works, but I didn’t notice clicking at the bottom is like clicking unfocus. Thanks for that! Any chance you guys could add some extra room at the bottom of the list when it’s a long list?

On the Light Iowan template there are no disclosure triangles. They are visible on iOS, and other templates have them, but not on the Mac. If there’s a way to show them that would be really helpful for the reasons mentioned… but even so, having a template with them hidden by default can make things extremely confusing, especially when they show on iOS.

I can certainly file a request for that. If you only focus on a single row, you can also cmd-click on it in the section list to unfocus that row.

iOS doesn’t support different visibility states for handles like the Mac does. That particular template is part of the Essentials set of templates which are designed to offer a range of styles and settings since Essentials does not have the ability to create their own templates. Some people like to not see the handles and that’s why the setting exists and a template with it set is offered. Yes, there’s no visual indication of the collapsed row and it’s intentional.

You can show the handles again by changing the Whole Document style:

  • Open the left sidebar to the Styles tab
  • Select Whole Document
  • Open the Inspector to the Selection Style tab
  • Click the option on the left for Handle, under the Row inspector.

1 Like

Thanks! I could swear I’ve tried the handles button before and it didn’t work… but maybe I didn’t. I’ll give it a whirl 😊