Keyboard assignment don’t come to effect

I usually change the keyboard shortcut for italics throughout all programs to cmd + 2. This shortcut worked perfectly in OO, too. After a recent reinstallation (version 5.8.2 PRO), however, OO won’t accept the assignment any more. The new shortcut shows up correctly under the menu “Shortcuts” below “Settings”, but in the menu “Formatting”, italics is now “blank”—neither the old “cmd + I” nor my choice.
I remember problems like this if there are other commands in a program using the same combination and override one’s own choice—but I can’t find any “cmd + 2” in the menu of OO.

Any ideas?
Thanks a lot!