"Line" menu greyed out?

I’ve been using Omnigraffle for about 2 years (I’m on v. 6.6.2) and I’ve created a number of lines in the past, with multiple variations of arrows. I’m not sure what has changed, but now when I create a line, all the options in “Line” menu to edit line attributes are greyed out. I’ve tried clicking around in other options and searched the support site, the forum, etc. and I don’t see it referenced.

Any suggestions?


Hi Todd,

Have you tried different styles of lines from the Style dropdown (area pictured below) when creating a line? Is it just one particular line style, or all of them? If you make a new document, does this still happen? If you are using a line style with a Fill setting, that is a connecting shape and not a line. If you use this style, you can set the fill and stroke, but you will not have any line options. If so, the style will look like this shape: LineToolStyleShapeInsteadofLine and once drawn, there will be shapes connecting other shapes instead of lines.

Feel free to contact us. If you are able to include the document where you are seeing this issue, you can choose Contact Omni from the help menu. There is an option there to replace all text with the letter x instead, to protect your privacy. We are glad to help!


I am having the same issue as Todd with v6.6.2 for Mac.
I don’t see a Style dropdown, and “Shape” options are greyed out. Suggestions? Thanks, GF

Hi GF,
What do you have selected on the canvas? It is the line tool? An existing line? Does this happen in every document, or just some documents?

If you have a shape like I am showing in the style well in the photo above, that is a “Smart Arrow” shape and not a line. That may be why the line options aren’t a choice if you have that kind of connection selected. If you tap the shape tool, you will notice one of the shapes is the “Adjustable Double Arrow”. A connecting smart arrow shape is not actually a line. To read more about “Smart Arrows” see https://support.omnigroup.com/documentation/omnigraffle/mac/6.1/en/drawing-basics/ under the heading “Smart Arrows”.

If you have a line selected, or the line tool selected with a line style, the shape options aren’t available because you are using a line, and not a shape. In that case, use the line and stroke options to change the appearance instead of the shape options.

If you are using a line to connect 2 shapes, it will not be one of the shapes you can see when you choose the shape tool and click on shapes. How do you know the difference? The simple rule is, if it has a fill, it isn’t a line. If it is a line, it doesn’t have a fill. Here’s an example that I hope will help:

By including adjustable shapes in our line styles, things got confusing. As of this year, we have stopped having smart arrows as a default line style in our latest OmniGraffle versions, so those who want to use smart arrows have to intentionally select them with the shape tool, which makes more clear that they are not lines. All of the line styles in OmniGraffle 7.7.1 are actual lines. We still support Smart Arrows, but they are no longer a default line style.

If this doesn’t explain what you are seeing, there may be a problem that I can’t reproduce here. Please reach out to use from the Help menu by choosing Contact Omni. We are glad to help! Sorry about the trouble.