Links to built-in perspectives - not working?

I think I’ve got a unique issue here and need help resetting the URL scheme.

Today I did two things:

  1. Finally upgraded to Omnifocus Universal Edition (from Legacy Edition) via the Complete my Bundle, as well as qualified for the free Pro upgrade by reinstalling OF version 1 on my iPhone. So I temporarily had three versions of Omnifocus on my iPhone (OF2 Universal, OF2 Legacy, and OF1).

  2. Tried playing with a new internal link setup, to click on URL to get me to other perspectives, projects, etc (eg omnifocus:///perspective/Forecast )

Then I stumbled upon my issue…

I had OF2 Universal open. I clicked on a link in a note (I believe it was omnifocus:///perspective/Inbox ). iOS asked me to approve “Omnifocus opening Omnifocus”. I clicked yes.

This, I soon realized, meant the link was now opening OF1 - at a setup screen (since I had only reinstalled it this morning but not set it up). I quit OF1, as well as deleted OF1 and OF2 Legacy.

However, now when I click on the URL within OF2 Universal, nothing happens.

I believe I need to somehow reset where Omnifocus links point, as I suspect they are pointed at OF1 - which is no longer on my phone. I could be wrong about this, of course.

Does anyone know how to fix this? Any help is appreciated. Thanks!


A couple additional details for clarification:

  1. All links worked fine last night from within OF2 Legacy - when that’s all I had installed. That is, each link opened the correct perspective from within OF2. So I believe the links themselves are correct (proper formatting, etc).

  2. The links seem to work properly from Apple Notes. Clicking an omnifocus: link there opens OF2 Universal to the referenced perspective.

[EDIT - I edited the subject line to more closely convey what I think is the issue]

After some further testing, I have now discovered:

  • links to custom perspectives work from within OF. For example, “omnifocus:///perspective/Dashboard” properly opens my custom “Dashboard” perspective

  • links to the built-in perspectives do not work. For example, neither “omnifocus:///perspective/Inbox” nor “omnifocus:///perspective/Forecast” link to Inbox or Forecast, respectively. These links do work from within Omnifocus on the desktop.

Oddly, the behavior is similar when opening the links from Notes app:

  • links to custom perspectives open the correct perspective

  • links to built-in perspectives merely opens OF2 but not the perspective - just the last open screen

I am not sure if my original suspicion is correct (related to OF1), but my base issue is now that links to built-in perspectives do not open properly.

Please someone tell me I’m missing something really obvious here. :-/

Hmm, good catch! It turns out OmniFocus for Mac and iOS are slightly inconsistent in this regard:

  • On the Mac, links to built-in perspectives require perspective/ in the URL, as you’ve discovered: omnifocus:///perspective/Inbox
  • On iOS, only links to custom perspectives use perspective/ in the URL. Built-in perspectives can be opened directly, using the lowercased name of the perspective – e.g. omnifocus:///inbox

Sorry about that! If it’s feasible in your workflow, you can get around this by constructing the URL for the platform you intend to open it on.

Thanks for bringing this bug to our attention!

Ah! Thanks for the explanation!

I look forward to this getting updated, but for now I can get by with two links.

Thanks again!

plans to fix it?

Hopefully this is an OmniFocus 2 quirk that can be corrected,

@tekl - do you have an update to this? I haven’t seen its fix listed in recent release notes, though may have missed it.

I’m afraid we don’t have any more information on this bug at the moment, sorry! As always, if this is significantly impeding your workflow, I encourage you to email support to let us know.