OF 2.02 won't open [A: issue in App Store affected multiple devs, fixed on October 4.]

I really feel fooled. Just installed the new version 2.02 in hope to fix the frequent crashes of 2.01. And again, it can’t be opened.
I am definitely done with this product!

The build we sent to Apple is working fine, so something seems to have broken in the App Store distribution process. We’re trying to reach Apple right now.


Update: it’s not just our app, it seems to affect other apps which were updated today:

Last update of Linky crashes on launch. It’s removed from sale. We’re sorry. It seems to be bug on the App Store and not an error from us.

So thank you very much for the really fast information. I am not sure, if this is good news for all of us, but I am glad to here, that it is not omni focus this time.

1 Like

Purchased Omnifocus for iPad yesterday night. Removed omnifocus from mac to do reviews only on iPad. Even upgraded to Pro version to haven custom perspectives and similar capability as on the Mac. It is Friday 6pm, as I get ready to do the the weekly review on the iPad. Omnifocus crashes!! removed the app, re-installed, nothing!! reset the iPad, removed the app again, re-installed, and still nothing!!
Are you suggesting I go back to my Mac now, re-install OF, resync the dB, etc.?

If your Mac has a copy of OmniFocus 2.0.1 for iPad, you can safely reinstall it on your iPad. (Also, anyone who purchased OmniFocus 1 can reinstall it.)

If you don’t have an older build, you’ll need to wait for Apple to fix the corrupt 2.0.2 distribution. I don’t know how long that will take; I’ll post updates as I can.

1 Like

More developers are being affected, it seems.

Edit: Correct grammar error, add another affected developer.

This is happening to me as well.

Bad luck, two major problems with the app, 1 week apart.

It does make me rethink a bit my leaving cloud based solutions.

I hope this is resolved soon.

Latest status: the problem with OmniFocus 2.0.2 for iPad is a general problem affecting any apps distributed today with embedded frameworks.

For developers who want to know more details about the embedded framework distribution problem:


Ok. Tried another installation from the app store and it seems to work again. Hopefully this will last another week or two. ☺

How did you get one that worked? It appears that it is still removed from the app store for me…

I don’t know. Just chose the version from my purchased list. But I am not sure, whether it is old or new. But it definitely works again.
Good luck!

Confirmed! Apple has fixed their App Store distribution of OmniFocus 2.0.2 for iPad. I’m marking it available now, so it should show up for everyone in an hour or two. (If you already downloaded the corrupt distribution of 2.0.2, this fixed distribution will replace it when you update the app.)

1 Like

Not yet in Spain

I see the update, but when I click on it, it says that’s it’s no longer available.

OmniFocus may still be unavailable for some folks right now. That’s expected: it takes a few hours for App Store changes to make it through all its servers.

I’d advise waiting an hour or two, then quitting the App Store app (or iTunes) and trying again.

1 Like

Same here. This is really getting stupid.

not working in Sweden

Still can’t get it in nyc. I see it, but says it’s unavailable.