OF 2 for ipad won't open! [9/27 Update: fixed builld rolling out to App Store now]

I tried to open OF 2 today and got a dialog box saying ‘this pre-release has expired, please install a new Build from Omni’. Anyone else seen this?

I am having the same problem - just started. Deleting the app and re-installing from the App Store did not fix it.

Same for me. I just purchased it from the app store and got “This OmniFocus prerelease has expired Please install a new build from Omni.”

Thanks for the response…saved me from deleting and reinstalling also. Let’s hope someone is around at the Omni office!

Same issue here. Just started tonight.

Agree, totally down, I reinstalled to no avail. I have emailed support, not sure what more to do at this point except wait.

I emailed support and sent the link to this thread. Hopefully we’ll hear back soon!

Same here. I’m sending a bug report, too.

I’m also having the same problem. I also tried deleting and re-downloading . Still does not open. I also emailed support. Lets hope it’s just an honest mistake and can be fixed quickly. I hope it’s nothing larger caused by the IOS update I have just applied.

Our deepest apologies, everyone! Our OmniFocus 2.0 submission was unintentionally marked as a test build, which meant it stopped working on Friday, September 26 (displaying the message “This OmniFocus prerelease has expired”). We’ve submitted an update that removes that test build flag so that the app will never expire. Once again, our sincerest apologies!

Hi all,

I am getting this message every time I try to open OmniFocus 2 for iPad

This OmniFocus preprelease has expired
Please install a new build from Omni

It then quits me back to the home screen.

There are no updates on the App Store for OmniFocus, so I have no idea what to do.

I just installed iOS 8.0.2, so perhaps that may be the trigger.

Any help ASAP would be much appreciated.



Just happened to me too. I uninstalled and reinstalled, no change.

Yup! Tried reinstalling too. Didn’t help

Is there an expedited Apple approval process possible? Or are we at the whim of Apple? If so, I’m guessing it would be OK to use the iPhone version on the iPad for a while?

We have requested expedited review but there is no timeframe attached to that designation.

I’m having the same exact problem and just emailed support.

Happening here too.

Will the app just start to work again or will we need to do a reinstall? Also, will we need to do another upgrade to Pro?

I’m getting this, too. Paid $29.99 for this app literally yesterday. I was expecting a premium product, or at the very least a product that actually works. Someone please reassure me that a) this will be fixed soon and b) this doesn’t happen often.

Edit: Just submitted a problem report to Apple and requested a refund. Unless they offer a free premium upgrade or something for the inconvenience, I’m moving on. Glad I didn’t get too attached, but I’m definitely disappointed.