OF keeps opening "for the first time"

Just installed OF2 on a MacBook Air. I’ve been using it successfully on my iMac for several months.

For some reason, every time I open the app on the Air it’s giving me the message that “Omnifocus is an application downloaded from the Internet…”, as if I had just downloaded it. I’ve tried trashing the Preferences files, but to no avail. Any idea what might be causing this? Thanks!

Solved! Just had to actually empty the trash. :)

Negatory. The issue has reappeared. Every time I open OF, it’s as if I’ve just downloaded it. Why??

This is really unusual! I’m not entirely sure why this might be. That message is usually triggered by the presence of an extended attribute on the application – OS X puts one of these attributes on apps as they’re downloaded so that when they’re opened, you see that prompt and have to explicitly indicate it’s OK to continue.

Would you mind checking a couple things and reporting back with the results?

  1. Where is your copy of OmniFocus installed? Most customers put it in /Applications, but a few run it from somewhere else.
  2. Once you’ve found the OmniFocus application, open a Terminal window. Type:
    xattr -p com.apple.quarantine
    with a space after the word “quarantine,” then drag the OmniFocus app onto the Terminal window. You should wind up with a command that ends with the full path to OmniFocus, like this:
    xattr -p com.apple.quarantine /Applications/OmniFocus.app
    Hit Return, then copy and paste the results of that command back here.

These two bits of info may give us some insight into why OS X is prompting you so frequently.

Wow, thanks so much for popping in, tekl. Here’s the result of that Terminal command:

0002;546dce15;Safari;76F3BC1A-BAA5-4C7B-8BD1-DC0FCCEDBB52

My copy of OF is installed in the standard place: at the top of the Applications folder. Thanks!

Huh. That’s certainly a value that would force OS X to prompt you for permission to launch the app. I would expect OS X to clear that value after you say OK the first time.

To work around the issue, you can use that same xattr program to clear the attribute. Quit OmniFocus, then run:

xattr -d com.apple.quarantine /Applications/OmniFocus.app

(The -d flag deletes an attribute, as opposed to the -p flag which prints it.)

If I were you, I’d also take this opportunity to run a disk check on your Mac using Disk Utility; OS X’s inability to clear this extended attribute is worrying me, in some nonspecific way.

Crazy. It doesn’t seem to have worked. I get this on the following line after I hit Enter:

xattr: [Errno 13] Permission denied: ‘/Applications/OmniFocus.app’

This might be why OS X keeps prompting you! If your user account can’t clear this flag using the Terminal, then the system can’t clear it on your behalf after you grant permission either.

You might try deleting the OmniFocus app entirely and redownloading it. In theory, putting a brand new copy of the app in /Applications should give it a new set of permissions, too. If that doesn’t work, I’d recommend sending an email to our support team – they’re great at diagnosing tricky situations like this. (You can even refer to this forum thread so they know what you’ve tried already!)

1 Like

Just deleted the app, re-downloaded it and installed, and so far I’ve opened it twice without the prompt! Fingers crossed… Thanks, Tim!

2 Likes

We finally managed to reproduce this situation in-house. In our case it was installing the app as one user (who doesn’t launch it) and then launching the app as a different user. Is it possible this is what happened in your case?

You know, I think it is possible. I haven’t had any issues since my last post, so I’m reaching back into my memory, but I think I may very well have installed it on a different user’s account and opened it for the first time in mine.

I tip my hat to your perseverance on this. Not only is OF a great app, but it’s apparently got some pretty meticulous bug quashers working on it as well! Thanks!