OF2 and Alfred workflow

In case anybody uses the workflow created by Teddy Svoronos (OF: Parse Tasks), here is the script edited to work with OF2 (key changes were to change the application name and use the new command “parse tasks into”:

on alfred_script(q)
set theText to q
tell application “com.omnigroup.OmniFocus2”
tell default document
parse tasks into with transport text theText
end tell
end tell
end alfred_script


Tip: don’t forget to restart Alfred! Thank you jsgreen!

What does this script do?

Intended for users of Alfred; this script connects Alfred with OF, enables a quick entry of OF tasks from the Alfred interface.

I use it all the time, just hit my Alfred keyboard shortcut and type in the task (preceded by the letters OF):

“OF send email to VIP client”

will put a task “send email to VIP client” in my OF Inbox

When i ran script, it froze my alred for a second and then asked me where is com.omnigroup.OmniFocus2

First time i had seen something like that happen. i did then choose the appropriate omnifocus in the dialogue box. i also had one on my backup drive. It then worked.

Is this a standard way to call omnifocus because haven’t had this issue with other scripts.

Thanks for the help.

I honestly don’t know if this is a standard way to call OF (I edited someone else’s script and I don’t have much applescript experience).

I don’t think it will ask for the appropriate OF again, it should just work next time you call it.

Hi JS - thanks for this. I’m curious: what’s the difference between this Alfred script and simply using OF’s Quick Entry Shortcut?

Not much difference, really. Using Alfred means one less shortcut to remember (my muscle memory is well trained to Alfred at this point). The quick entry might give more options (project, start dates context…) but I usually just add those when I process my inbox.

I don’t know if this is true - but doesn’t the quick entry have to have OF running? Using the Alfred shortcut doesn’t rely on having OF open, so works all the time.

I see. And yes, OF does have to be running for Quick Entry to work.