OF2 Extremely Slow To Open due to SIMBL plug-ins?

Opening Omnifocus 2 takes approximately 90 seconds on my MacBook Pro. Solid state drives, 16 GB RAM, OSX 10.9.2. Uninstalled and resintalled with no success. Time is the same with no library or my full library. When I right click on the icon in the dock, i get an Application Not Reponding error for the 90 seconds it’s working to open.

Anyone else see anything like this?

1 Like

Yes, I’m getting the same behaviour. Same Mac set up.

Thanks, glad to know I’m not the only one. I’ll submit a bug.

the same here.

Request to merge this thread with the existing one.

Would like to leave this thread open as the performance issues referenced in the other thread are extremely different from this startup issue. Thanks.

Right apologies about that. Missed that minor nuance.

I’ve reported this to the support ninjas.

Additional detail: when starting in safe mode, startup times are pretty much normal and quick. I’m wondering if there is a common login item that we are running that is causing the issue.

This is definitely not how long it should be taking! On my MacBook Pro, OmniFocus 2 launches within four seconds.

Did your launch times improve at all with the performance updates over this weekend? If not, could you please take a sample of the app so we can figure out what OmniFocus is spending all its time trying to do?

Thank you!

Thanks Ken. I took a sample this morning and sent it to the beta support email. I also included an additional sample from an Apple process (pboxd) which also becomes immediately unresponsive at the same time that OF2 is launched. This appears to be a sandboxing process. My uneducated guess based on some research seems to indicate that this process is used when opening files from sandboxed apps. I also get the message below when opening OF2, which fades away after 5-10 seconds but does not show anything else. Please let me know what you see. BTW, loving OF2 overall!


1 Like

Some additional info. on this issue which I shared with Ken after he reviewed the samples I took:

  1. With the most recent two builds, I can no longer replicate this issue. OF2 opens in approx. 4 seconds are you stated on the forum. I have rebooted and am running the same processes and apps as before. Glad to have it fixed, but not certain as to what fixed it.

  2. I booted into safe mode and then opened OF2. It took 7-8 seconds to load, which is not bad comparative to normal as safe mode is always slower. This would indicate that there was a startup process somewhere causing the issue.

  3. There does not seem to be an account issue as I used my normal admin account for the safe mode testing.

  4. If I see the issues again, I’ll run sysdiagnose as suggested so that we can narrow down the culprits.


1 Like

Hi, I am having the exact same issue as jaworthen, including the 90 second delay on opening, same issue with processes, yet most recent builds have not fixed this in any way. I also have a MBP, SSD, 16GB RAM, 10.9.2.

Should I also send you a sample? When reviewing activity monitor while it is trying to open, four processes are in red, including OmniFocus (Not Responding), SIMBL Agent (Not Responding), com.apple.security.pboxd (Not Responding) and PowerboxInjector (Not Responding).

Please advise as I am loving the new OF2 but this is posing a major difficulty in usage.

I also have still the same issue.

When I looked into jaworthen’s sample report, here is what I wrote back:

Thanks for sending that sample in! It looks like OmniFocus is just idle, waiting for the system to grant access to its lock file.

Meanwhile the Apple process you sent in a sample for is also idle, also waiting for the system to grant access to one of its own files. At first I thought maybe it was waiting for OmniFocus and they were in a deadlock, but then as I looked more carefully I realized it was looking for its own internal script suite (which OmniFocus can’t even access from its sandbox).

So at this point I’m starting to think that there’s some other process involved which is the underlying culprit for all of this. You could try quitting some other applications and extensions to see if you can narrow it down that way, or you could run the sysdiagnose command in Terminal to collect information about everything that’s running and we could try to sort through that together to see if we can figure out what’s causing the delay.

You might also try creating a new account on your Mac and launching OmniFocus 2 from that account just to see whether the delay is associated with account configuration or your system configuration.

Thank you very much for reporting this and for helping us track it down!

We didn’t get any further than that, because the problem went away. But I wonder if SIMBL might be the process that everything else is waiting on? Could someone take a sample of that? (Or just try disabling SIMBL to see if that makes a difference?)


I had EasySIMBL installed to run a hack called Colorful Sidebar which returns color icons to the Finder sidebar. I activated SIMBL earlier this afternoon and did not have any problems starting OF2 with it active or deactivated. I really wish I could reproduce the error now but am not able to.


I have the same issue, and installed Colorful Sidebar yesterday…

Re-titled the thread to bring it in line with current understanding as of last couple of posts in the thread.

To Ken and everyone:

This thread has been appropriately re-titled as it certainly appears to be SIMBL (or EasySIMBL). I had this installed to run SideEffects 1.9 which is similar to Colorful Sidebar (color icons in sidebar). I uninstalled both and OF2 opened within seconds. I re-installed the hack (and EasySIMBL) and the problem returned. The problem was again rectified by uninstalling.

Would a sample of SIMBL help? I would love to be able to use SideEffects again in the future. Is there any plan for “fixing” this to allow them to coexist, or will OF2 never be able to run effectively with EasySIMBL installed?

Nice work to ken and all for finding the issue.


It’s not at all uncommon for SIMBL to cause issues like this; it’s also not something we generally (or ever, that I can remember) spend engineering resources trying to support in our apps.

If a given plugin works w/out causing issues, that’s great. Live and let live, right? :-)

Same here. Deleted “Side Effects” SIMBL app which restores color to Finder Sidebar and OF2 started up in a flash, instead of the usual minute.