Omnifocus crashes on mac sierra

I don’t know if it’s sierra, or a data corruption issue, but I now cannot open Omnifocus 2 for Mac. It opens the main window, then goes immediately to crash catcher before closing. I’ve re-installed the latest version from the Omni website, same thing happens. I haven’t had any problems with other software on my system.

Of course I’ve sent the official crash report in, but is anyone else, running sierra, experiencing this? I’d be curious to know how widespread this is.


For me OF 2 works flawless on Sierra. Updated last week, no problems so far.

Are you running the latest OF release?


thanks for the reply - it was working fine for me, until I tried to open it this morning. As I said in my initial post, I’ve re-installed the latest version from the omni website, and it still crashes.

OF 2.7.2 OK with me on 10.12.1. Could it be data corruption? Did anything else unforeseen happen recently? Have you a backup to restore from, and try that - maybe on Time Machine from yesterday? Sorry - and good luck!

thanks, yes, it’s all backed up, and it’s normally synced with my ipad and iphone versions so no worries there, but i do like to do my organising on my mac, so it’s a bit of a nuisance for now.

problem solved

downloading a new copy and re-installing over the original didn’t work, so I downloaded and installed a legacy version - 2.0.4 - which, when i tried to open it, showed an error message, but then the dialogue window about a newer version appeared, so I clicked ‘download and install’ (ver. 2.7.2) and it opened fine, with all my current data intact. i hope it’s ok now, it seems to be.

I had the same issue. 2.8.3 crashed after I created a new Project using the entry box just below each task item line. Then, each time after that, it would crash when trying to open the program. I uninstalled and reinstalled 2.8.3 to no avail. Finally uninstalled and installed 2.7.2 and it opened without issue. I then used the dialog box asking to update to 2.8.3 and it seems to have installed ok.

Just wanted to say that I had the same issue and you’re not alone.

same issue here recently. will try your “fix” thanks.

That fixed it thank you