OmniFocus for Mac & ios Devices Suddenly VERY SLOW SYNC

I’ve been an Omnifocus user sycing among a Mac, iPhone & iPad using the OmniGroup Server. Suddenly, a few days ago syncing became painfully slow. A sync on any of the installs started taking at least a few minutes, often many minutes.

In the past I learned how one must be actively syncing on all devices to keep the speed up & filesize low. I use the Mac version far more than the iOS Devices for OmniFocus. So when it slows down at all, I make sure to sync all devices; sometimes it takes multiple tries, but it has always solved the problem. But not this time.

I’ve tried all sorts of things to get the speed back & nothing has worked. One of the things I tried was archive old data, since it had been at least a few months.

The problems started around the time I replaced my iPhone 7+ (running iOS 11.x) with an iPhone Xs Max (running iOS 12). I made sure there were no devices registered for syncing besides the correct 3. Except for 1 short time period … the iPhone had removed suddenly reappeared! So far this seems to be ok now.

Here are more specific descriptions of what I’m running:

MAC: OSX 10.13.1 (High Sierra); Omnifocus 2.12.2

IPAD PRO: IOS 11.4; OmniFocus 2.22.3

IPHONE XS MAX: IOS 12; OmniFocus 2.22.3

I’ve been planning to update all to OmniFocus 3. But I want to get everything running OK first. Any ideas what could be causing the sync problem & how to fix it?

Also, any suggestions for the least problematic approach for doing the OmniFocus 3 upgrades?



I haven’t noticed slow sync yet. I am on OF 3 across the board (just upgraded the last Mac this morning) and sync across several phones, tablets, and Macs.

I upgraded my iOS devices first because that version came out first. On each device, I installed the update then chose the option to sync with Omni Sync when prompted. I did one device at a time and there were no problems running OF2 and OF3 simultaneously.

The only backward compatibility issue i noticed was when I first archived vex old items on my main Mac. It mentioned that the v2 archive format was different than the v3 version. It created a backup of the archive before upgrading it. All machines are happily on v3 now.