OmniFocus won't launch [Fixed with 2.8.2 and 2.7.4]

For some reason when I click on the OmniFocus icon I immediately get the message ‘OmniFocus quit unexpectedly’. I have turned the MacBook Pro on and off, tried to launch via the finder applications folders but still the same message. That’s really the extent of my technical skills so any pointers as to what I should do would be really appreciated.

I’m getting the same message. I tried reinstalling the app but still no joy. Opens on IOS with no difficulties and I haven’t changed any settings on my mac so no idea what the issue is.

I"m getting the same message as well. Would love to know how to resolve it.

Are you using the latest build of OmniFocus (currently version 2.8.2)? We renewed our Developer ID last month and shipped a new developer provisioning profile in version 2.8.2, but older releases were using a profile which was associated with our older Developer ID which was scheduled to expire today.

If you missed 2.8.2 in software update for some reason, you can always download the latest build here:

Sorry for the trouble!

1 Like

I’m getting the same error on Yosemite, using version 2.7.3. Including when I try to open a backup of my omnifocus file.

I got the error a day or so ago about an expired profile and followed the instructions to fix that. Everything was fine until this morning.

I just upgraded to Omnifocus 2 for my iPhone. Any chance that’s causing the problem?

It won´t launch for me neither. I´m on Yosemite 10.10.5 and Omnifocus 2.7.3.

I was going to update to 2.8.2 (I’m running 2.7.3) but at the top of this page I see “v2.8.2 requires OS X 10.11”. I’m running 10.10 and intend to stay there for a while.


Again, sorry for the trouble! The latest build is OmniFocus 2.8.2, but it requires 10.11 “El Capitan” or 10.12 “Sierra” so that doesn’t help those of you still using 10.10 “Yosemite”.

I’m putting together an updated Yosemite-compatible 2.7.4 build now, and we’ll get it posted ASAP. It won’t have the latest improvements from 2.8 (global search and so on), but at least it won’t crash on launch!


Dear kcase,
I use Yosemite, too, but I am also using 2.7.3. Even tried older versions. All of them just won’t start since this morning.

I’m on Yosemite too, and neither my desktop or laptop will launch. C’mon, guys, you’re hurting my productivity for the day! Please fix!

To recap:

We renewed our Developer ID signature last month and shipped a new developer provisioning profile in version 2.8.2, but older releases were using a profile which was associated with our older Developer ID which was scheduled to expire today.

Anyone who is using OS X 10.11 “El Capitan” or OS X 10.12 “Sierra” will want to grab the latest OmniFocus update here (currently 2.8.2):

For those still on OS X 10.10 “Yosemite”, we’ve published an updated OmniFocus 2.7.4. It doesn’t have all the new features from 2.8 (so we do recommend upgrading to a more recent operating system when you can), but at least it does have a renewed provisioning profile!

Hope this helps! If neither of these builds solves your problem for some reason, please let us know.


Thank you thank you! This works!

I installed version 2.7.4 and it synced only tasks, I’ve lost all my customizations (icons for the perspectives, layouts, settings). Please help!

Were you using the Mac App Store edition of the app before? If so, you should continue using that copy. (The two editions sync their data, but have separate settings.)

That did the trick. Thanks a ton for the super fast turn-around!

No, Omnifocus Store. I have Omnifocus for Iphone and Ipad though.

I think that what messed up this solution for me was that I deleted v. 2.7.3 before updating to 2.7.4 and I have Hazel automatically deleting the application support files.

I have those files still on the Trash, but no idea where to put them. Any ideas how to fix this?

Oh, that makes sense!

I’m not quite sure how Hazel trashes those files, but if you select them in the Trash do you have the option to put them back (using File > Put Back in the Finder)?

If using File > Put Back doesn’t work, all of the support files live in our app’s sandbox container, ~/Library/Containers/com.omnigroup.OmniFocus2. (You can get there in Finder by using Go > Go to Folder and entering that path, “~/Library/Containers/com.omnigroup.OmniFocus2”.) Maybe you could restore the whole thing using Time Machine?

If not, most of the relevant settings are stored in the com.omnigroup.OmniFocus2.plist file, which belongs in the Data/Library/Preferences folder inside that sandbox container.

Sorted. Thanks for your help

Fixed. Thank you!

Hi Ken, that didn’t work out but I found out I only lost the customizations on the toolbar and a few settings. All the perspectives are still there, which is a relief, I recently spent hours making everything look beautiful.

This kind of issues is exactly why I hold off updating to sierra, even at the expense of the new features.

Anyway, thank you so much for getting into it so quickly!