“Permission is needed to open attachment"

I have quite a few notes that link to files on my system. I can’t embed these files, since I use them heavily outside of Omnifocus too. For example a “Review Expenses” task will link to an expense report.

I regularly have issues with Omnifocus requesting permission to open the files. I understand it’s MacOS thing, and nothing can be done about that. However, the process to grant permission is horrible. Here’s what it looks like for me:

  1. When I click on the linked file the standard MacOS Open File Dialog is displayed with the permission-needed text. It opens to the default location (which is a completely different folder from where the linked file is).
    2a. I need to either find the file (painful) and press Open. Or:

2b. I press Open to open the default folder. This changes the link in my notes to the default folder.
3b. I undo the change to the now. The link is now reverted back to the original file link.
4b. I click on the link a 2nd time, the file now opens.

If OmniFocus doesn’t have permission, isn’t there a more simple flow to grant it permissions? Could it discover it was missing permissions and simply pop-open the Open Dialog and tell me to press the “Open” button (blindly). That would grant it permission and it could go on to open the link as I had requested?

Are others facing this same quirky flow - maybe there’s something I’m missing.


1 Like

I actually sent a mail to support earlier today, before I read your post, after having this problem for a long time. In my case it’s easier, as I have most of my attachments collected in the same folder, and that is the folder that Omnifocus opens. It’s still annoying, though. What I wasn’t aware of until recently is that Omnifocus only asks for permission if I have made changes in the attached document since the last time I opened it from Omnifocus. As some of my attached files are reference files that I only view, not edit, I don’t have the problem for those. For other files, I have been considering only making references to their names in Omnifocus and opening the files using Launchbar instead, which in my case would be almost as quick. But let’s see what support answers.

1 Like

What happens if you set the permissions in the Finder (Cmnd-I > ‘Sharing and Permissions’ at the bottom usually) to files you want to open from within OF?

You could try this on Mojave: Go to System Preferences, Security & Privacy, Privacy, Full Disk Access and add OF.

Would be kind of extreme though, to grant this level of access to OF ;-)

The Omni Group support has now confirmed that this problem exists. As a workaround they recommended me, if possible, to use the Notes field to place a URL to a dedicated file repository where the file is saved. They mentioned Evernote as an example:
Inside Omnifocus: Links between OmniFocus and Evernote

Thanks all!

That’s promising news @Jan_H - did they provide any ETA on the fix. If it’s not going to be solved anytime soon I’ll either try to play with permissions or try to get urls working.

Sorry, no ETA for a fix, and no promises that they will be able to fix the problem, so try to get urls working sounds like a good idea. I tried a little changing permissions, but I don’t think that is the problem, as OF already had rights to read the documents. You may also like to consider Launchbar: a keyboard command to activate Launchbar, a few characters in the filename typed, and then return. To me, that is almost as convenient as having links from Omnifocus.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.