Perspectives not applying "Focus on" as expected? [Fixed in r209607]

This is something that happened some versions before and hasn’t been fixed yet: When I select some custom perspectives OF2 won’t switch to the pre-set focus for the perspective.

I’ve to click several times back and forth until OF2 finally switches to the correct perspective with the right focus.

1 Like

Hmm, I don’t recall hearing anything like this, and I’m not seeing any issues in my own custom perspectives.

Could you provide more detail? Are these perspectives configured to show contexts in the sidebar, or projects? Are they focused one thing or more than one thing? Folders or projects or both?

1 Like

I sent in a report of a similar problem today that involved being focused on sixteen projects but no folders. The focus was respected on an original perspective of those projects but was not respected on a perspective created by Edit → Duplicate on that original.

Thanks for that update. When you get a chance, would it be possible for you to attach both of those perspectives to that ticket so we can try to compare what’s different between then? You can attach an archive of a perspective definition to a mail message by dragging it from the Perspectives window to Mail’s Compose window. (This attaches the definition of the perspective, but it uses anonymous identifiers for any referenced items—so we’ll be able to see the perspective name and icon, but no other personal information should be included.)

1 Like

I’ve seen this problem pop up a few times as well.

I wanted to log a bug request or post a topic here, but haven’t been able to really isolate what exactly was happening, or what I did to enable me to recreate the problem.

But I’ve seen it 3 or 4 times when switching around in different custom perspectives - the main task window gets stuck and doesn’t seem to change to reflect a change in perspective.

I’ve had to quit and restart the app each time to resolve it.

I can now pinpoint the reason what is causing this: If You select “Active” under Filter project it is happening. If you select “Remaining” everything is solved and focus works as it should.

Here are the screenshots of the perspectives where this is happening (doesn’t matter if context or project):

So if I create 2 perspectives with a different focus, it won’t switch between the perspectives. It only works randomly or if I quit and restart.

I have a similar problem w/ my perspectives. I already sent feedback to Omni.

All my @contexts perspectives (“don’t use project hierarchy”) are broken at Mac. On the iPhone and iPad everything works fine.
E.g. I got a “Today’s projects” perspective. Settings:
Group actions by Context
Sort actions by Project

Filter status: Due or Flagged
Filter by avail: Available
Any Duration
Filter: All contexts (I tried every other settings from active to remaining)

Neither Focus nor Sidebar Selection

Another Perspective is a System Ritual (Daily Habits): also @Contexts Perspective.
The settings are the same, except:
Filter status: Any status
Focus on (Folder): System Routines

What happens is: When I start OF2 and click through all my @Contexts perspectives, it works fine. But when I switch e.g. from today’s project perspective to system routines, the viewings mess up. I see other tasks which do not belong in there or the perspective shows nothing at all.

I have had a similar problem since yesterday.

I have succeeded in narrowing down the conditions under which it applies here. The problem of perspectives not switching focus when switching between them (I have two perspectices which give me due and flagged tasks for business and private contexts respectively) only happens when I switch between them using the sidebar (i.e. when the perspectives are given a “star” in the “Show perspectives” window).
I also have icons for both perspectives in the toolbar. If I use them (and they are not shown in the sidebar) the focus switching is no problem.
This is a somewhat convoluted description. I still hope it helps to track down and squash that bug.

My observations are similar. The problem actually also exists with the search box. The observation:

I have a custom made perspective (let’s call it ‘A’) that includes a search term (‘xyz’) in the filter. When I select that perspective ‘A’ in the sidebar, it properly displays what I expect. And the search box at the top shows ‘xyz’. When, as a next step, I then:

  • would click on another custom perspective ‘B’ in the sidebar, all is well and the results of that other perspective ‘B’ are shown, search box is empty
  • would click on a built-in perspective ‘Z’, the search field is not cleared and still shows the term ‘xyz’, and therefore showing different results of what I would expect from that built-in perspective. This seems to be true for all built-in perspectives, including the Inbox and Review.
1 Like

Same here. reported this one a already as well, still present in r209463… switching from one custom perspective to another messes up the sidebar big time- practically renders perspectives useless- this would be a mandatory fix for 2.0 with perspectives being one of the hallmark features…

1 Like

Problem still there in revision 209491. Agree with @mat_rhein that it makes using perspectives troublesome: one cannot trust them anymore. The start of it all seems to coincide with other problems as reported in this topic. Must be a hard to find/solve problem.

1 Like

Look for a fix to this bug in a build later this evening.

1 Like

The weird thing is that for one change of perspectives it works- and then freezes up. First I thought a refresh by switching from a project-based to a context-based perspective might help as a workaround, but it didn’t…

HAHAAAA- fixed in v87 r209607… I would have thought this really deserves a mention in the release notes ;-))) … thanks Ken!

It happened to me this morning, but has not happened on this latest build yet, it was always sporadic for me.

Hmm… perspective focus seems solved. But Revision 209618 is not completely there yet as far as my example from above with the search box is concerned. What remains is a less worrying issue: the search box is not cleared when changing perspectives, but however is not applied. Given my example above, it still says ‘xyz’, but this search term is not used to filter what is shown. Relative to the perspective focus, it is a minor issue. But still some work to do.


I’ve noticed that once in awhile a perspective will show every single project. I check View and it is Focused on the right projects. I noticed when I click on several other perspective icons and go back to the initial one, it is as it should be.

I feel like I’m doing something wrong, but I don’t remember this problem more than a week or so ago. Any ideas? Thank you!

This sounds like a case of Perspectives not applying “Focus on” as expected?, which should have been fixed in yesterday evening’s builds starting with r209607.

1 Like

Yes that is it. I am not sure why I did not see that before, sorry for the duplicate.