Pre- and post-spacing for rows


#1

With OO 3.x you could set the spacing before an after each row at a particular level. This appears to be absent from OO 4.x. Why so? I found it tremendously useful.


Control indentation per row level
#2

This was removed to reduce the complexity of all the spacing options. From the questions and feedback we’ve received over the years, it was clear that these were causing confusion for a very significant portion of our users. There were also some oddities about how those values interacted with each other we wanted to resolve. We acknowledge there are those that understood and used those settings to their full potential. There was much debating over this change so don’t think it was just done on a whim. Numerous alternatives were discussed before settling on what shipped in v4 and we felt this was the best compromise that supported as many uses cases as we could while still making it easier to understand. If you would like to share your use case of the missing features we’ll certainly take it into account for future changes. Thanks.


#3

My use case is pretty simple, and I’m surprised that more people don’t want to do the same — I want to be able to generate a well-structured PDF of my outline where the spacing between sections depends on the section level. Using Markdown, consider the following:

(page break before)

Level 1 heading

(24 pt spacing before)

Level 2 heading

(12 point spacing before)

Level 3 heading

(6 point spacing before)

Level 4 heading

It’s very common to adjust the spacing before and after each heading based on the depth of the heading.

As it is, the absence of this feature in OO4 forces me to use OO3 or some other tool entirely.

BTW, thanks for the detailed reply. Although we may not agree on the importance of this feature, I appreciate your response as well as all the great work you Omni guys do.

Cheers.


#4

Can this not still be achieved using a combination of row padding and above/below children values? Maybe just above/below children values? (Or maybe you’re not aware we moved the features other than row padding to be pro-only?)


#5

I think it’s a shame that basic formatting features such as adding space below a line, that really, really help readability, should be considered PRO only features or dropped.

As soon as you want to share an outline with someone, this becomes a necessity - and frankly it is just for readability.


#6

Any plans on re-instating this feature? It’s absolutely essential for publishing outlines unless you are willing to do post-editing work (which should not be necessary). More importantly, I question why you would remove a valuable feature like this. I suppose it’s somewhat simpler not to have it, but you could argue that for every feature. Look at the way you guys do styles. That is arguably one of the most complex style mechanisms I have every encountered. It’s far more complex than adding space before and after a paragraph. Every word processor on the planet has that feature, and I don’t hear a lot of people complaining about it.


#7

I just assumed that I was doing something foolish because I could never get sensible spacing. I didn’t realize it was a feature that had been removed. I confess to not knowing how to best implement it (that’s why you get the big bucks :)), but it’s the most natural thing to have in a document: You have topics, subtopics, etc, and then before you start a new topic, you want there to be a gap at the END of the previous lower-level topic. For example, if I have a file about students, I have basic info, and then more detailed subtopics. Then I of course want a gap at the end before I start the next student information section. Please consider returning this. It’s not a deal-breaker for me, as I love OO, but it always makes things look weird not to have it. Perhaps you could have it off by default, but with the ability to turn it back on as an advanced option in the preferences. Filtering, which I know is a priority for you, is far more important, but this matters in being able to make documents that need sensible-looking formatting to show publicly.


#8

This is possible if you have the pro version. You would want to set the “Below children” value for each topic.

However, there is a bug with the outline view not automatically updating as you change that value. Toggling the sidebar should get it to update after changing the Below children value.


#9

@swehba
Does this file not reflect the use case you posted a couple years ago? http://people.omnigroup.com/dmo/outgoing/abovechildren.zip


#10

I can’t get this to work at all now. Even on 4.6. I know it used to sort of work, though it never did quite what I wanted. By the way, Omni should consider making a quick tool that replaces the text in a file with junk text so that people can share files that have problems without disclosing the contents of the file. I thought that that exist for OF already, though maybe I’m mixing it up w/ some other software? Anyway, something to consider.


#11

I did just upgrade to OO4 from 3, and actually I’m using OO5 alpha. And since I updated, I’m struggling with the formatting of rows. I just thought I oversee something, so I was looking on google and found this thread. I can’t believe, you removed spacing before and spacing after! This was very, very useful and MUCH easier to understand then “Above children” and “Below children”. And also, since nothing happened when I changed “Below children”, I couldn’t find out what the parameter does. So I tried everything to format the document the way I wanted and did nearly getting mad over it! Who could think of that this is a BUG which is still in OO5!

Please Omni, bring back “spacing before” and “spacing after” and make sure “spacing after” is actually working without the need to hide and show the sidebar! Thanks!


#12

DerekM, thank you for visiting these forums and explaining why Omni has made this decision.

Printing at less than 14pt with no added vertical space is one use case that potentially can be improved. Any time the font size is less than 14pt, phantom vertical spacing seems to show up in the output:


#13

Thank you for the explaining your use case, aurelius. That is always very helpful information when bugs and features and being discussed. However, the issue you’re running into is not what’s being discussed in this thread. The white space you’re encountering at small font sizes is not controlled by row padding in any version of OmniOutliner. Nor is it controlled by line height. Line height applies to the text inside a row:

37%20PM

The issue here is the minimum height allowed for a row. This is because there are elements other than text inside a row that are interact-able, such as the row handle, note icon, checkboxes, calendar, and pop-up menu control. As well as needing to provide adequate sized elements for many other interactions like drag and drop and selection.

I have filed your request to better accommodate small text sizes.


#14

Minimum height to accommodate interactive elements explains what I was seeing. Thanks for the quick review and for submitting the request. I’ve edited my earlier post.