Property inspector broken again

Yes, this is a bug that has been reported.

As a workaround, uncheck the option in Preferences to Hide inspectors that don’t apply as shown here:

Sorry for the trouble and I hope that it is something we see resolved, but until then I’d disable it.