Resolving “Calendar requires authentication” errors

There is a support article on this topic here:

But I thought I’d post about it here as well in case anyone has an easier time finding this information here in the forum.

Note: The OmniFocus Reminders calendar is an old feature that we added before other newer features that probably accomplish its goal better. If you’re still using this calendar and want to keep doing so, read on! If not, you may want to simply turn it off all-together.)

➤ Repeating Calendar password prompts on iOS can be caused by two different things (that we’re aware of), sadly neither is controlled by OmniFocus itself. That said, the following actions seem to get the prompts to stop…at least for a while.:

1.) Make sure the calendar is not syncing through iCloud.

2.) Delete the password from Keychain (then manually re-enter).

➤ To address both of those ↑ see below ↓:

1.) To remove the calendar from iCloud, make sure the setting on the Mac is set to “On My Mac” following the steps here:

(Note: After doing that, if you still want the OmniFocus Reminders calendar on your iOS device(s) as well, follow the instructions in this support article for setting that up:

2.) To delete the calendar password from Keychain follow the steps here (make sure you get them all and know the correct password to re-enter!):

1 Like

Deleting the iCloud Keychain did the trick for me. Also note what the support document says:

“Changes to iCloud Keychain can take some time to sync their way to all of your devices, so we recommend waiting at least 24 hours after making these changes to see if the prompts stop.”

After deleting my Keychain from all devices I also deleted the passwords stored inside iOS 11. I waited for 1 day and checked if they were still there. After all passwords were gone and 24 hours passed, it worked again.

1 Like

Is the Problem still there? Can I activate my keychain synch again? Right now there is no problem with keychain synch off regarding to calendar suscription

It shouldn’t be necessary to totally disable iCloud Keychain for all of the apps that sync via your Apple ID. You do however want to a) make sure you’ve deleted any iCloud Keychain entries for your Omni Sync Server account credentials (sounds like you did that!) and you’ll need to make sure that your calendar subscription isn’t set to sync via iCloud. Steps for that can be found in the Support article Anne linked above.

1 Like

Ok, so just to make it sure. My calendar suscription is synching locally and not through iCloud and working well in the calendar. My iCloud Keychain Synch is disabled and on my Mac I have stored the Password for OF. So what do I have to take about now if I want to use iCloud Keychain synch again, without anything crashing? Can I just turn KeychainSynch on again on my Mac and iPhone (since there are no double entries passwords for OF anymore?). Thank you!