Some contexts from 1 aren't appearing in 2... help?

I had a “Waiting” context that was brought over from Omni 1, but does not show in the sidebar in Omni2. Yet whenever I start typing “Wai…” in the context box, the “Waiting” from Omni 1 appears. How do I get rid of this? Thanks


UPDATE:

I just realized that all the “waiting” contexts were hidden due to an option. Fixed it.

Just in case anyone else experiences this and looks here for help: try clicking on the View button in the toolbar (which looks like an eye).

Adjusting the options there will (barring a bug) let you reveal items which the current settings may be hiding.

True, but the wording is confusing. I was looking for contexts that are active in OF1 but don’t have tasks attached. I couldn’t find them in the Context view in OF2. When clicking the eye I can select to see more TASKS, but all I want is to see more CONTEXTS. When selecting ALL tasks, I can see all my contexts, but it took me at least 10 minutes to figure that out.
Also, I can’t select contexts by state, which would be a good thing to easily manage the contexts.