Startup problems after updating to 2.4 version

I have strange startup problems right after I updated to 2.4 version.

About 60-70% of every try to launch omnifocus i get following screen, white screen after that and everything stops.

What could cause this problem?

OmniFocus 2.4 (v91.2.0.221594)

Best regards

Oh that is the new design they spent months refining. Do you like it?

That is a progress indicator. OmniFocus needs to take a little more time to load the database before it can show you anything useful. If you’re seeing this very frequently, there may be something slowing down your database. It’s possible our Support Humans can help make it snappy again:

Problem emerged when OmniFocus was launched via Launch -app. Next OmniFocus version had a bufix for this problem.

Same thing here with the new version released today (2.4.3). The new version hangs while/after syncing. Same database I’ve always had.

It’s working now after deleting and reinstalling it on my iphone 6. I tried reseting the db, unregistering all devices… nothing worked, it hanged while syncing every time.

After reinstalling it, is working fine again.